Etcher v1.5.33 can't find usb drive in windows 7

support
#1

I have been using Resin.IO Etcher 1.3.1 without any issues and like it very much. However, I recently installed Balena Etcher v1.5.33 and tried to flash a Linux image to a usb thumb drive and received the message that Etcher could not locate a portable USB drive.

So I proceeded to flash Linux using Resin.IO Etcher v1.3.1 and it worked perfectly.

Only after this does v1.5.33 now see my portable USB drive. Is there some kind of issue with Windows 7?

#3

That’s very strange. Thanks for the report! Now etcher is able to discover your USB drive reliably? If it again cannot see the drive, can you try to check in the debug console if there’s any error? You can bring up the debug console with pressing Ctrl+Shift+I

I’ve also opened an issue on the Etcher issue tracker, feel free to add any details there if you have!

#5

Sorry to take so long to respond. Family commitments.

  Oddly enough it did the same thing today when I had just inserted

a USB stick into my PC. It showed as O: drive in Windows 7 File
Manager, but not in Etcher v1.5.33. However, I had just
re-installed a USB WiFi dongle and this may have caused some
issues on my machine.

  I restarted to computer to finalize the WiFi installation and

this time Etcher located it and flashed Manjaro Linux with no
issues.

  I can only assume that the problem was "user error" because I had

been trying to correct a WiFi connection issue I was having. I
think Windows could not locate the dongle (USB) and this may be
the cause.

  This is good news for me as I am an inveterate software tinkerer

(a retired IT professional) and really like Etcher. I also run a
few Raspberry Pi and ASUS Tinker-board computers, so Etcher is my
go to tool of choice.

  Thanks for your assistance and quick response. I'm currently

installing a fresh Windows 10 boot-able drive so Etcher has been
useful once again.

So far things seem to be functioning as the should.

Cheers. Ian

#6

Great, glad it works for you. Thanks for the update.