Etcher shows only a Blank Screen when trying to run it Linux Mint 19.1 Cinnamon 64 bit


I am using Linux Mint 19.1 Cinnamon 64 bit and I have Chromium installed and I am trying to run Etcher version balenaEtcher-1.5.50-x64.AppImage.

All I am presented with is a blank screen and this error or comment from the program in the terminal “Checking for update Update for version 1.5.50 is not available (latest version: 1.5.50, downgrade is disallowed).”

I also a Ctrl + shift + i and I get the following errors in the dev tools in chromium
“Uncaught Error: /tmp/.org.chromium.Chromium.PpLGIm: failed to map segment from shared object
at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:166:20)
at Object.Module._extensions…node (internal/modules/cjs/loader.js:740)
at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:180:18)
at Module.load (internal/modules/cjs/loader.js:620)
at tryModuleLoad (internal/modules/cjs/loader.js:559)
at Function.Module._load (internal/modules/cjs/loader.js:551)
at Module.require (internal/modules/cjs/loader.js:658)
at require (internal/modules/cjs/helpers.js:20)
at Object. (/tmp/.mount_balenaSD…ash/lib/xxhash.js:4)
at Object. (/tmp/.mount_balenaSD…sh/lib/xxhash.js:52)
at Module._compile (internal/modules/cjs/loader.js:711)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:722)
at Module.load (internal/modules/cjs/loader.js:620)
at tryModuleLoad (internal/modules/cjs/loader.js:559)
at Function.Module._load (internal/modules/cjs/loader.js:551)
at Module.require (internal/modules/cjs/loader.js:658)”

Can someone please help me out and tell me how to fix this so I can run the program. Thanks.

Hey there! Are you mounting /tmp as NOEXEC by any chance? Can you running Etcher with a different TMPDIR? For example, create /home/<username>/tmp and run TMPDIR=/home/<username>/tmp ./balenaEtcher-1.5.50-x64.AppImage from the terminal


I am not sure if that is what it is doing. The command I use is sudo ./balenaEtcher-1.5.50-x64.AppImage and then it launches. I will try what you suggested above and get back to you. Thanks.

Ok, that worked. So what do i need to do so it knows this now all the time so I don’t have to do it manually again?
Thanks again.

Awesome! You need to make sure /tmp is mounted with the exec option in your system. See

Cool, I will thanks again for the help.