Etcher says it worked but it didn't

Hi so what happened was I downloaded Etcher based on the instructions from this page… Tails - Install Tails from macOS

Then I downloaded a disk image of “Trails” operating system (also tried the torrent download) Both the file and the image were verified by the above page verification.

So then I told Etcher to flash the above to a new 64G thumb drive (usb3). The thumbdrive was flashing and Etcher says it worked

however the thumbdrive does not show up in my finder window however Disk Utility see it however disk utility says there is nothing on the thumbdrive (its empty)

additionally, the thumbdrives (TD) came packaged in a group of 3. When I first plus the TD in, it shows up in the finder however after using Etcher, it disapears. Even unplugging it and plugging it back in makes no difference. Turning the machine on and off, makes no difference. Did Etcher kill the two TD’s so far? Im reluctant to try the last one.

Im on 2008 Mac Pro Tower (desktop) El Capitan (10.11.6)

video card is

NVIDIA GeForce GTX 960:

Chipset Model: NVIDIA GeForce GTX 960
Type: GPU
Bus: PCIe
Slot: Slot-2
PCIe Lane Width: x16
VRAM (Total): 4095 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x1401
Revision ID: 0x00a1
ROM Revision: VBIOS

(if that makes a difference)

I also asked the trails people but they have an auto reply saying they don’t reply to mac problems.

Any suggestions?

thanks for your help,



Etcher writes to block devices using the operating system’s own APIs, so it’s incapable of damaging hardware. I’m not familiar with that particular distro, but what probably happened is that Etcher wrote the image to your disk, and your OS doesn’t have a driver for that Linux filesystem. Try booting it and see if it works.

That seems to be another problem. I was told when I bought the new video card that it would not allow the boot screens. I’ve tried holding the option key down but it still just boots as normal into ElCapitan, so maybe it doesn’t see another option? Or how else can I get to a screen that would show the options?