Etcher not loading on Win7

Probably not of concern to most and I’ll prepare for an “UPGRADE PLEASE” response lol. Sorry. AM2+ socket. Anyways.

BalenaEtcher is opening, but not loading on Win7 x64. I tried flipping through changelog info for both Etcher and Electron, but can’t really decipher the footnotes. I did find that Electron dropped support for Win7 for v23+. But, I can’t tell when they released v23, or if Etcher upgraded to v23 somewhere along the line of updates. It usually took a while to load with previous versions I have used, but still loaded up after a minute or two.

I have tried Etcher v1.14.3 and v1.18.1 (both portable) and the installer version of v1.14.3. The window opens, but just hangs with a blank white screen.

If there is a dependency support issue for Win7 (my best guess is moving from Electron 22 to 23?), does anyone know the last version that did work with Win7 OR the last version using Electron 22? Or perhaps there’s a chance this is a major bug? I have seen a few reports of Etcher not loading in various OS environments.

My specs in case they’re useful:
AMD Athlon 64 X2 5200+ (2.7ghz, Brisbane)
AMD R7 250 2GB GDDR3 (OEM)
2x2GB DDR2-800


@terraping It might be worth checking in with the version v1.7.9; based on the thread here: Need help installing BalenaEtcher on windows 7