Etcher not burning mbr only gpt

All of a sudden when I create a bootable usb stick, it returns “Operating system not found” when I boot from it. this usually happens when you’re booting a uefi with a legacy bios or vice versa. I have not changed from legacy to UEFI and never had a problem with etcher before. I if change boot mode to UEFI then the usb stick boots up. etcher is now only flashing in gpt or uefi mode at least for me it is. anyone else have this problem?

Etcher does not create or modify the partition table. That already comes with the image that is being burned. If a burned USB stick only boots in UEFI mode, then that’s because the image itself is not compatible with non-UEFI BIOSes, and vice-versa.

lhanks for the response. I understand what you are saying. but I was burning an arch linux iso from may 2020 and it always booted up fine in legacy mode. just recently it doesn’t anymore. It’s actually very weird because any image I’ve burned within the last week or so, the same result. Machine is not in UEFI mode. so they just don’t boot anymore. I have to go into a win 7 vm and use rufus and that works fine. Like I said earlier, I have never had a problem with etcher before other than like in the last week and it’s the same version that was fine before and now, not fine. very strange

Hi, Etcher has no guarantee to make a drive bootable, it entirely depends on the image you write as the application itself doesn’t perform any changes to the source. You can read more on bootable drives here etcher/ at master · balena-io/etcher · GitHub and, as you mentioned, you might need to use a different tool like Rufus (which sounds like it worked already from what you said)