Etcher giving ErrorI do not understand and incorrectly flashing USB-Stick

Etcher flashes my USB. Everything seems normal to me. But when it is finished it gives me an error and the USB-Stick only has a 4mb partitition on it. And booting with it does not work.

(I’m very new to this.)

Hey Buddy, hope you are good
this same thing happened to me when i first flashed my usb it happens everytime whenever i flash my usb with the help of etcher
but i noticed something i flashed my usb with other flashers also and what i observed is that the different flashers were also causing the same issue i flashed it mutiple times with almost more than 10 flashers but the error didn’t solve
then what i did is to redownload the iso of the operating system(linux mint 20 cinnamon)
and what happened
it worked i flashed it with softwares such as rufus,unetbootin,universal flaher
i didn’t flash it with etcher because i didn’t trust etcher after the incident happened to me of the error
can i know what operating system you were trying to flash

  1. The last thing i would like to say
    is that don’t use etcher if this error still comes after the new flashing


Thank you for your reply.
I will try out the solutions you told me.

I am trying to Flash Manjaro XFCE 20.1.2-201019.

ok thanks

Hello. We often get asked about these types of issue - please see this forum thread BalenaEtcher turned 128GB into 4MB?

Got it done with the Manjaro again and also used Etcher but on the Laptop of a friend with his iso.

hey buddy
can you redownload the iso one time and try again
sometimes it also works and
please try to flash it with etcher if this comes again
then don’t worry format your pendrive to NTFS and then try again it also worked for me
i know buddy it is complete time wastage for trying things again and again
to come to the final point is that don’t use etcher use other softwares
that will be more good

Hi Ayush

Seems like you have taken to going around the forum and asking people to not use Etcher.

  • I see that you ran into issues with Etcher and one of your devices. Were you able to resolve this?
  • I am sure someone has linked you to the Etcher Killed my USB blog post ( - did you go through it? Did any of the things mentioned work? If not can you let me know what didn’t or did work?
1 Like

Hey, hope you all good
i didn’t assumed anything not to make people use etcher
i also rememmber when etcher did it with my pendrive everytime
i use it
that’s why i am saying switch to other softwares if possible
according to your question

the thing etcher did to my usb was it breaks my usb everytime
and the only solution of this problem is of formatting the usb flash drive after installing the operating system in the hard disk but it breaks everytime with every os iso

but i am not facing the problem in booting
i think so this is the problem of etcher or iso

Hello Per, good to know that finally it worked!

We have a similar issue solved on this forum thread

Thank you for your answer Ayush.

We do agree that sometimes the experience to flash usb drives and SD cards is complex, this is why we built Etcher.

The main goal of this forum is to help users with issues using Etcher and balena and learn from these issues. The most important at Balena is to learn and improve the experience to reduce friction of the users getting into their projects.

You are welcome to help users with Etcher and as well to help us to improve Etcher.

hey per
did it worked buddy
or you are facing the same issue again