Etcher made my SD card hard read-only.

Opened a brand new sd-card, ran it through h2testw to be sure it was genuine capacity and then used the latest Etchera to flash a Rasplex image to the card. Running windows 10.

The card wouldn’t boot in the raspberry pi. I put it back into my PC and i can’t do anything to it. I can’t format it, i can’t delete the partitions, i can’t change the partition size, nothing.
I’ve tried 3rd party partition tools and they behave as if they’re doing the job but at the end when they refresh the drive view, the sd-card is back to being a rasplex card.

I’ve loaded Ubuntu on my spare machine and use gparted to delete partitions, but that fails too.

I always always always use Rufus for flashing but the guide i found for Rasplex said to use Balena. Awesome.

@burnt-sd Sorry to hear the issue you are having. Can we check on the couple of things here:

  • Is this a full size SD card with the physical lock which might be enabled here?
  • What kind of error do you receive once you try deleting or modifying partition?
  • You mentioned the card is brand new, but seeing some of similar post around point to hw issues as well. Can we try formatting via official SD association tool: SD Memory Card Formatter | SD Association?

Hope to hear back soon.

Regards,
N

It’s a micro-sd card, i’ve tried multiple adapters, all with the same result.

When using the windows disk manager, there is no error, it just doesn’t update the disc. If i select to delete a partition, it pauses for a second, then refreshes to show the partition hasn’t changed.

If i use the official SD association tool with a quick format, it completes and shows the info tab with the “new” partition size and partition name, but when i click refresh it resets the device name to the old partition.
If i try to use the overwrite format, it fails after a few percent and says “formatting failed”.

If i use EaseUS partition tool, i tell it to delete the partition, it behaves as though it has done the work, shows a completion page, but then refreshes to show the partition hasn’t changed.

I’ve googled and this seems to be a regular problem with Etcher.