Etcher has bricked 4 USB Sticks and 3 SD Cards

Have tried to use the stock instructions for flashing Tails, have used only devices that are not on their list of problem devices, both sticks and PCs, have used 3 different PCs, result is always the same. In one case Etcher actually bricked the dedicated SD Card slot of the laptop which was fun.

Cannot recommend enough to not use this for Tails. I am out $200 and a micro SD card port that I was very fond of.

Hey @etcherretcher, it’s unlikely that the drives are broken, merely they’ve been put into a temporary and reversible state by an incomplete flash. You should have success in restoring them using the “Recovering broken drives” section from the Etcher docs [1].

As the micro SD port, could you describe what diagnostics or symptoms indicate that it’s broken?

[1] https://github.com/balena-io/etcher/blob/master/docs/USER-DOCUMENTATION.md#recovering-broken-drives

Yes that’s the first thread I went to, tried everything there.

Ah, that’s more troubling. I wonder what could be happening with your drives?

If it’s not too much trouble, could you share:

  • the version of etcher
  • the model of the drive
  • the cmd output when attempting to clean the drive (as per the etcher recovery docs)

This would help us to determine what’s going on here.

Additionally, the windows tool chkdsk might be able to turn up some useful information. [1]

[1] https://docs.microsoft.com/en-us/windows-server/administration/windows-commands/chkdsk

1 Like