Etcher doesn‘t start on Windows 10, 64bit

Hello support team
First time user here. While installing today was easy, The app doesn’t even start. Photo shows my system:

Any idea how to solve the problem?
Thanks.

Hi Dan, welcome to the forums. The very first thing I would try is to launch Etcher with Admin privileges, which might be as easy as right-clicking on it and choosing “Run as Administrator”, if your user account in Windows has that ability. The second thing to try, is to use the “Standalone” version of Etcher, which you can download from balenaEtcher - Flash OS images to SD cards & USB drives, click on the down-arrow next to Download, and select “Etcher for Windows (x86|x64) (Portable)”. Thanks!

Thanks for your answer and doubting my diligence. Before opening this thread I checked the hints in the similar ones but I couldn’t deduce a specific hint for me except trying opening it as an administrator, which had no effect as I am the only user on my computer thus having administrator rights from the start.
However I tried only the standard installer (v 1.5.122), not the portable version. Please allow me a few days to try and I will report about the results.
Btw. I was directed to your website by Roonlabs.
Kind regards.

Using the „portable“ version, installing and flashing was a breeze.
I didn‘t check yet the flashed USB, but the process was without hassle.
Thanks

Glad to hear that worked @Goodsound. Its likely an issue with a local setting, security profile, antivirus, etc. that is killing the local-installation version. Either way, if the Standalone version worked, then that is great. :slight_smile:

The Flashed USB stick did his job. But now how can I reuse it as a standard stick? It is an 64 GB one, but now shows only 199MB usable and can not be formatted or repartitioned?

You will need to repartition it back … flashing bootable Linux images leaves them in a weird state, yes. You can follow the Windows instructions in this article: Etcher broke my USB stick … or did it?