Etcher on Windows 10 stuck on "starting"

Windows 10 Home version 1903; Etcher version 1.5.66. Got stuck on “starting.” I searched these forums, tried again running as administrator. Now it says it can’t find any removeable drives. I’ll try an earlier version if I can figure out how to get it.

Hi, can you check if there are any errors in DevTools console? You can open DevTools by pressing Ctrl+Alt+i

Okay. Ctrl+Alt+i didn’t do anything.

Just to clarify at this point, the program has successfully launched / started, and you have overcome the first error, of it being stuck, correct?

Assuming that is the case, what is the device type you are attempting to flash? A USB stick? An SD Card? Does Windows recognize the device as inserted properly? Perhaps even rebooting the PC might be a good first step.

Thanks!

Thank you for quick reply. The program launches, I can select the image, select the SD card as F: drive (recognized by Windows,) then when I select Flash, it says “starting” and stays like that. Ctrl+Alt+i does nothing.

I uninstalled Etcher and used Win32DiskImager successfully, solving my immediate issue.

Today I reinstalled Etcher 1.5.66 and tried again on a different SD card, just to follow through with this conversation, if it’s helpful. This is a new Windows computer for me; I have used Etcher successfully on my old computer. Both are Windows 10 64 bit. I stay current with updates. Both have AMD processors. The image I was installing is here: https://downloads.raspberrypi.org/raspbian_full_latest.
I’ll reboot and retry in a little while.

Hi,
Thanks for keep trying it. It is definitely very helpful for us, so that we can find the issue and fix it. Please let us know about your results.

I have the same problem. I tried to use another software (Rufus) after that. When running or starting, the process was stopped by my antivirus program (Sophos Home).

Could Etcher have the same conflict?

Hi, can you try to launch etcher with admin permissions? (Run as administrator)

Also, regarding to antivirus, can you disable it and then flash an image to see if it’s related?