Etcher does - nothing!?

Ever since the update to 1.5.120 on my Mac Book running Big Sur Etcher does not flash (at least SDs) any more. Test on Windows with the same Etcher version, same Flash card and same image works just fine.
Any image file flashed to SD or emmc (on usb-adapter or directly) fails.
The source is chosen, the target is chosen, flashing is chosen, the flash window opens, asks for password (I’m) not running on admin) and ist back to Etcher window. No error. Reinstalling etcher did not help.

Heres some Data from the console where the cancellation appears:

Tue May 25 2021 15:40:17 GMT+0200 (Mitteleuropäische Sommerzeit) SafeWebview loaded ({“event”:{“id”:21,“url”:“Etcher Featured Project 200”,“statusCode”:200,“responseHeaders”:{“access-control-allow-origin”:["*"],“age”:[“518”],“alt-svc”:[“h3-27=”:443"; ma=86400, h3-28=":443"; ma=86400, h3-29=":443"; ma=86400"],“cache-control”:[“max-age=600”],“cf-cache-status”:[“DYNAMIC”],“cf-ray”:[“654f2cb14abe416f-HAM”],“cf-request-id”:[“0a455a42d40000416feb3bb000000001”],“content-encoding”:[“br”],“content-type”:[“text/html; charset=utf-8”],“date”:[“Tue, 25 May 2021 13:40:16 GMT”],“expect-ct”:[“max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct””],“expires”:[“Thu, 20 May 2021 04:41:00 GMT”],“last-modified”:[“Thu, 13 May 2021 23:04:08 GMT”],“nel”:["{“report_to”:“cf-nel”,“max_age”:604800}"],“report-to”:["{“endpoints”:[{“url”:“https:\/\/a.nel.cloudflare.com\/report\/v2?s=PSCbGfdOudIMBjk1yjgQMKT3V4%2BQOFxTZ2mgiKakHc7A1wipT8vqF9OWSYnBxDqkoUZIjNczr%2BzhfnMAFDWT2P1vcYWTDSkE26JSoOKmwBajF5htLtuL6GzLDrsJ0w%3D%3D”}],“group”:“cf-nel”,“max_age”:604800}"],“server”:[“cloudflare”],“vary”:[“Accept-Encoding”],“via”:[“1.1 varnish”],“x-cache”:[“HIT”],“x-cache-hits”:[“1”],“x-fastly-request-id”:[“587f32c399915b1e65daed24fc5d13f08d64484e”],“x-github-request-id”:[“70BA:C6AB:9E1AE:A8C74:60A5E604”],“x-proxy-cache”:[“MISS”],“x-served-by”:[“cache-fra19154-FRA”],“x-timer”:[“S1621950016.231358,VS0,VE1”]},“referrer”:"",“error”:“net::OK”},“sample”:0.1,“applicationSessionUuid”:“ffbb2383-903b-4caa-a570-e37b4cadd8d1”,“flashingWorkflowUuid”:“e9daafa7-deed-48a3-a0fb-a7c80a7c04d1”})

gui.js:51110 Terminating IPC server

gui.js:51110 Flash results

  1. {cancelled: true, skip: false}

gui.js:51110 Tue May 25 2021 15:40:21 GMT+0200 (Mitteleuropäische Sommerzeit) Elevation cancelled ({“image”:{“size”:2261778432,“name”:“batocera-5.26-xu4-20200527.img”,“hasMBR”:true,“partitions”:[{“offset”:1048576,“size”:1992294400,“type”:12,“index”:1},{“offset”:1993342976,“size”:268435456,“type”:131,“index”:2}],“extension”:“img”,“path”:"/Users/danny/Downloads/batocera-5.26-xu4-20200527.img"},“drives”:[{“size”:15634268160,“isVirtual”:false,“enumerator”:“DiskArbitration”,“logicalBlockSize”:512,“raw”:"/dev/rdisk3",“error”:null,“isReadOnly”:false,“displayName”:"/dev/disk3",“blockSize”:512,“isSCSI”:false,“isRemovable”:true,“device”:"/dev/disk3",“busVersion”:null,“isSystem”:false,“busType”:“USB”,“isCard”:false,“isUSB”:true,“devicePath”:“IODeviceTree:/PCI0@0/PEG2@1,2/UPSB@0/DSB2@2/XHC3@0”,“mountpoints”:[{“path”:"/Volumes/SHARE",“label”:“SHARE”},{“path”:"/Volumes/BATOCERA",“label”:“BATOCERA”}],“description”:“TS-RDF5 SD Transcend Media”,“isUAS”:null,“partitionTableType”:“mbr”}],“driveCount”:1,“uuid”:“d2bfd56f-8ece-492d-a17f-4d91bfd439a8”,“status”:“cancel”,“flashInstanceUuid”:“d2bfd56f-8ece-492d-a17f-4d91bfd439a8”,“sample”:0.1,“applicationSessionUuid”:“ffbb2383-903b-4caa-a570-e37b4cadd8d1”,“flashingWorkflowUuid”:“e9daafa7-deed-48a3-a0fb-a7c80a7c04d1”})

Hi, can you check if balenaEtcher has permission to access removable devices? You should be able to check this using the following steps:

  • Open System Preferences then click Security & Privacy
  • Click the Privacy tab and scroll down to click Files and Folders
  • Check the apps listed to see if balenaEtcher is added and has permission to access removable devices.

A file has been uploaded using Jellyfish: Jellyfish

Hello, did you manage to fix the issue?