Etcher broke my USB stick … or did it?

Hi everyone,

There is something really strange with Etcher. Indeed, two of my USB stick were down after using it. I use Etcher on Mac OS Catalina to create a install media of the OS. This work just fine. I was able to install Mac OS Catalina. But after, when I need to format de USB and use it for something else, here is were issues starts. USB seems clearly to be unfunctionnal.

On Mac OS, I can see the install media created. But when I try with disk utility to do stuff, it is not possible. If I try the command mentionned here, not working. It is the same for Linux. I can see the install media created but I can’t do anything on it, even with the terminal.

On Windows, the disk is restricted, I don’t have the write permission to do what I want. I have use cmd and also diskpart with chmod, clear attributes, etc… even regedit. But no way to use the usb again. With AOMEI, I can erase the disk but that all. All the rest is not available because of the fact that disk is not mounted or sometime dynamic. It seems to have no partition et no volume on the USB. The format is stil GPT.

I am stuck between “You don’t have to permission to write” and “Error E/S”.

@dtischler Could you please provide me some help as the last USB key was working just perfectly and now its dead…

Thanks a lot

Hi @R41L, sorry for the delay here. First question to confirm, is that the image you flashed to the USB stick was a Mac OS Catalina .iso or .img file? Was that Apple’s official installation media file, or, you generated your own? (Is that an option somewhere in a running Mac OS, perhaps??)

Next, on Windows machine when attempting to clear the USB stick, are you running CMD and DiskPart as an Administrator? If not, local account permissions might not be enough. Similarly on Linux, if you are using utilities there, try running them as root. Let’s see if that helps, to start.

I would like to add that every single time I have used Balena Etcher it has made my USB totally unusable/unrecoverable. I thought it was a problem with the specific distro, but no: It does this every. single. time. it is used.

1 Like

Well, I’ve tried everything in the post, and the comments below, and these two drives are still bricked ie write protected.

As to your assertion that your software does nothing that could possibly do this is obviously simply not true. Looking on the SanDisk website, it seems this write protection mechanism is something that is built into the firmware of these drives to protect data when the drive’s firmware controller thinks it has detected data corruption.

So your claim that it was not your software that causes the drive to brick itself is nothing but a lame word -play ie - a lie - that I could perhaps best illustrate with a physical analogy.

Say there is someone sitting right on the edge of the roof of a high rise building, and you are walking along, near them, and behind them.

You give them a push, gentle, but enough to move them a couple of inches, enough to push them off the ledge, which leads to their death, caused by the long fall to the ground. Your defense is that you did not kill them, your push was gentle and only moved them a couple of inches.

There should be a large clear warning on your software and your website warning people using SanDisk drives NOT to use your software, as it is clearly capably of easily incorrectly triggering the failsafe locking feature built into this particular hardware……

Thanks for nothing, guys.

PS I agree with the previous poster - EVERY SINGLE TIME I used Etcher, it bricked my drive. I spent a lot of time trying to recover the first one it bricked, so I thought that perhaps it was the drive, so I used ANOTHER brand new drive (of the same kind Sandisk) with the software (the first one Etcher destroyed was a new drive also.). It gave me the exact same error after the formatting process, and bricked that drive unrecoverably also.

WARNING TO EVERYBODY. DO NOT USE THIS SOFTWARE WITH NEW SANDISK DRIVES!

Hello @pixelwash

I’ve been a heavy user of etcher for years with many different sticks and sd cards and never “bricked” any.

As this thread seems to prove, there’s definitely a combination of drives, adaptors and images that causes a device to look bricked when flashed with etcher.

Can you tell us more about the combination you tried ?

What David meant when it says it cannot brick your device, is that etcher is simply copying byte per byte the data from the image to the disk. It’s not doing anything funky with those data, nor the disk.

To continue your analogy, it’s more like if etcher had walked behind the guy and say hello like a polite person. Then the guy fall.

As I’m not been able to replicate the issue yet, It’s hard to dig into it, so the more info you have the better. I’d like to find a way to add safeguard or auto-repair if it’s possible.

@Balena team:

Just a thought: If you cannot replicate the issue, maybe you could try the following:

  1. Ask people if anyone might be willing to replicate this on their machine with you joining them via teamviewer or sth similar

  2. Provide a postal address (maybe only to some selected users) where people can physically send their bricked sticks, so you can investigate

Cheers
Ph.