Etcher broke my USB stick … or did it?

hey i have an 8gb sandisk cruzer usb pendrive that was “stolen by etcher” and i have no idea how to fix it, btw im using Linux lite 5.6 and the disks application sees the drive but it says that there is only 2.1 MB available and the rest is unallocated and i also cant see it in the file manager and no desktop icon appears when i plug it in

Can you tell me exactly the configuration of Rufus you used to recover your drive? I have a flash drive ‘bricked’ by Etcher and I’ve been fighting with recovering it for months now. When I try Rufus, I get this error.
image
This drive has been working reliability for me for quite a while and I have a tough time believing it happened to fail right after using this program when others have complained about the same problem.

Today i flashed Debian iso on Etcher for Linux x64 and it ends as successful flashed to my 16gb usb stick, when i restart pc and press f9 to make first boot usb it wont detect so i unplug device and turn pc on. This “sudo dd if=/dev/zero of=/dev/xxx bs=512 count=1 conv=notrunc” in terminal helps to see usb stick on boot option but after came another failure !

It sounds like you have now deleted the USB stick @Razor_Mcmxi, but a quick test would be to flash it with Debian once again, then try it in another computer and see if that other computer recognizes it when booting. No need to go actually go through the installation of course, but, just see if it is recognized.

100% this definitely resulted in bricked USB, on two completely different USB sticks. Thank god for Rufus. If it was that easy for me to replicate it should be easy for your development team as well, Windows 10 64 21H2

Bricked +1. I have a new Kingston Canvas Pro 64GB V30 microSD and this piece of s…oftware converted it to very nice piece of plastics.
Rufus didn´t help, the microSD card acts like it has never been inserted to card reader.

What image did you attempt to flash @jonlew? What OS are you running on your laptop or desktop? “Acts like it has never been inserted to card reader” is a bit strange…can you insert it in another computer and see if it’s recognized there?

I spent almost the whole day searching for the solution of “unbricking” and I managed to find it!:slight_smile:
I must say that my criticism was simply harsh and I should apologize for that. I will tell you the whole story and believe that anyone can find some pieces of useful information in attempt to fix the problem. So:

Using Win10 64b Home or what kind of version it is for home purposes. I downloaded an image of Manjaro distro from official site. I had a brand new 64 GB microSDXC that was reporting and acting correctly in my laptop card reader.

So I flashed this distro using Etcher to this new microSDXC. All went well, successfull and so on. But after flashing the microSDXC was not visible in commander like it has never been inserted to the card reader. Nor RPi booted with it. Card not responding (not detected as drive in commander, not detected as disk in diskpart, simply like dead). So I couldn´t even reformat it as it wasn´t detected by any means.
So I borrowed an ancient card reader at work - card not detected, dead. So I used an internal card reader (not so old) in one of the desktops. The LED started to light so it recognized the card, it was NOT dead! It DID connect as a drive in commander. Anyway Windows 8 with that internal card reader wasn´t able to work with it. Couldn´t copy, delete, format, nothing. It just showed that SOMETHING is connected as a drive.
So I used a card reader in a new laptop of my colleague. It showed everything as it should. Three partitions, data, everything. It had no problem reformatting the card, in other words it worked NORMALLY. So I formatted the card, merged partitions etc. and the card was like new.
Then I went and bought Verbatim card reader stick to USB3 that supported SDXC. Then I used imager to flash Raspbian to my microSDXC card and it went well. RPi booting with Raspbian.

So:

  • Etcher might be working well as long as you are using SDXC compatible card reader. My laptop card reader works with SDXC but is of older date. Etcher might be using processes that my card reader can´t handle correctly with connection to SDXC standard.
  • I have no time/will to test Etcher again with freshly bought Verbatim card reader that REALLY supports SDXC (I believe it would go ok)
  • My problem is probably with the card reader. I didn´t find out if Etcher was working properly or not, I can´t tell.

Hello, I am affraid you are very wrong. The software did kill 2 of USB keys when I tried to make bootable Endevour OS from the iso image.
The first usb was very normally functioning sandisk extreme 64GB.
Based on what I was reading about the problem - inability to recover the partitions, I bought a new sandisk 256GB usb disk.
After trying to make the bootable usb, I got exactly the same result.

DISKPART> clean

DiskPart has encountered an error: Access is denied.
See the System Event Log for more information.

so the Etcher DID KILL both usb disks.

Unbelievable. I am lost for words. The worst possible software ever.

hello, did you manage it in the end? I have exactly the same problem.

I’m another victim. Downloaded LinuxLite ISO onto my Win10 20H2 PC. Formatted my older 8GB USB to FAT32 (quick format). Started Etcher, it ran for a few seconds and failed. Now, I can’t format the USB. Diskpart > Clean does not work “Access Denied” and the event viewer reports:
Event 5 - VDS Basic Provider - Cannot zero sectors on disk \?\PhysicalDrive1. Error code: 5@0101000F

HTH
Gabe

Hey there so I used the Etcher a number of times on a single new, Sandisk Cruzerglide 32gb usb stick. It created multiple partitions of about 300kb every time I did this, and I tested around 6 different distros of Linux in a single night. After that I needed to Etch a windows iso onto the stick for a friend of mine but since Balena can’t do Windows I tried to use the Windows Media Installation tool. However since the Etcher made multiple tiny partitions on the stick, the tool was only reading 300kb of storage on the stick. All I had to do was delete the partitions in Disk Manager, perform a long format of the stick and making it back into ntfs from fat32 and the stick was fine. I have had no problems with it since then. Some of these problems with dead sticks might be that while windows itself cannot format the drive properly using diskpart, manually deleting the partitions that the etcher makes and performing a long format after might work for a few, as it worked for me.

Thanks for the note @idiot - good advice to help folks that don’t fully understand recovery. Perhaps I will roll that into the Blog post! :slight_smile:

@janfr – Open dispart and select the drive as per the guide, then:

DISKPART> clean

DiskPart has encountered an error: Access is denied.
See the System Event Log for more information.

DISKPART> convert gpt

DiskPart successfully converted the selected disk to GPT format.

DISKPART> create partition primary

DiskPart succeeded in creating the specified partition.

DISKPART> format quick fs=ntfs

  100 percent completed

DiskPart successfully formatted the volume.

I just downloaded and flashed Endeavor OS to replicate your setup. Upon completion, I attempted to recover. I had to use an extra step, convert gpt, as it seems Endeavor uses a different partition table. Let me know if that works.

Hello David, thank you for your reply. Yesterday I managed to correct both of the usb sticks with just diskpart = after I have added StorageDevicePolicies key in the Registry. (WriteProtect = 0 value).

I guess the way you did it is safer.

I appologize for freaking out. I really thought the usbs were gone. I understand your point that the SW is not able to brick the device.

:+1:

hey , nothing is broken, i found the way!!! HiveOS M.2 New Install No Show | How To Fix HiveOS Not Posting After Flashed On SSD - YouTube

it saved me… after 3 night of rage

solved with the instruction in this comment. But why I wasn’t able to do the same (convert to gpt) with AOMEI Partition assistant? And why this is happening to everybody? I’ve to use again Etcher, but don’t want this to happen again