Etcher broke my packages

(ubuntu 18.04.1) i installed etcher, rebooted some time afterwards, and got this:

when i put sudo apt-get update in the terminal, i essentially get the same thing:

E: Type 'sudo' is not known on line 1 in source list /etc/apt/sources.list.d/balena-etcher.list
E: The list of sources could not be read.

anyone know a fix? i’m pretty pissed.

also, for additional context, i attempted to install etcher via the terminal using the github instructions but i got confused and i couldn’t get it to work, so i tried with the appimage and it worked - i assume it must have been a problem with me f****ng up with the terminal installation

hello? i haven’t been able to update or install anything since this first appeared! this is really making me mad!

It looks like a malformed list.
Could you paste the output of the following command here:

sudo cat /etc/apt/sources.list.d/balena-etcher.list

E:type sudo is not known on line 1 in source list /etc/apt/sources.list.d/balena-etcher.list.

Same here,this is what i get when I run sudo cat /etc/apt/sources.list.d/balena-etcher.list

sudo apt-get update
sudo apt-get install balena-etcher-electron

Thanks for the help…

@Reggie971 @throwaway2193921

The error message is quite explicit: Type 'sudo' is not known on line 1 in source list /etc/apt/sources.list.d/balena-etcher.list

This means the first line of the /etc/apt/sources.list.d/balena-etcher.list file starts with sudo which is not expected by apt.
This file should contain exactly this line deb stable etcher
Update the file or remove it, then you’ll be able to sudo apt-get update again.