Error while flashing .DMG image with MacOS: Checksum does not match for range

Hi, everybody!

For a few days I am trying to flash a USB drive with a .DMG image using MacOS, with no success.
Of course, before starting a topic here I googled tons of materials for hours, as well as been going through this forum and a lot of different posts, but I decided to start a new thread, since this error is pretty well covered among Windows 10 users, but not MacOS.

I have a .DMG image, whose MD5 hash has been checked and matched after a download. The USB drive in question has previously been formated in Disk Utility, with 1 partition and Mac OS Extended (Journaled) and GUID Partition Map.

After selecting an image in Etcher and the USB drive, Flashing succeeds in approx. 20 mins., but then Veryfing begins. After 3% of Veryfing it immediately goes to: “Flash Complete! 1 Failed device”, and when you hover on the “Failed device”, you, of course, see an “Checksum does not match for range” error.

Funny enough, afterwards I can access both partitions in a flashed USB drive: Main and EFI one, with all the necessary contents of the image.

But when I insert a flashed USB drive into a desktop PC, its BIOS wouldn’t see the USB drive at all, even tough I can access all the partitions and its files on MacOS.

There is nothing wrong with the USB drive itself, because using other methods and/or a to make the USB drive bootable, that specific desktop PC can recognize and boot from the same USB drive with no problems.

I started this topic, because after few days of constant troubleshooting I runned into a wall.

It would be really amazing if anybody could give any insight and input about the issue.

Have a great one, folks!

Hi @mp3003

Welcome to the forums!

It’s important to note that Etcher does not do anything besides flashing the image, which explains why the drive is not bootable after flashing (see here for more details).

As for the verification failure, it does seem to indicate some faulty sector on the USB drive… Have you tried testing using different ports to connect the USB drive to during flashing? If this gives the same error, could you perhaps test flashing the same image to a different USB drive or SD card on the same MacOS?

Let us know how it goes.

Kind regards