Error downloading update


devices are having this issue after I pushed an update:
Failed to download application ‘…’ due to ‘rsync exited. code: 12 signal: null’

Devices are on multiple network so it is not an internet connection related issue.

Hi @diegosucaria
What supervisor and OS versions are your devices running? We’ve seen similar bugs in the past and fixed them in newer supervisor versions, but there might be other edge cases that still lead to a scenario like this.

In any case, you can work around the issue temporarily by disabling deltas (RESIN_SUPERVISOR_DELTA = 0 in your fleet configuration) so that devices download the image with a regular docker pull.

Disabled delta updates… the full image started to download fine.

Glad to hear. We have a few fixes for deltas in progress that should make this errors less likely. After the devices finish the download, you can turn deltas back on - if you hit this error again please let us know so that we can do a deeper dive (it will probably involve us taking a look into what’s going on in the devices).

1 Like

I am having a similar issue after having deltas turned off, then turning deltas back on I get the same repetitive messages as above, but with code 2.

Turning deltas off will allow the device to successfully download and run the app, but turning deltas back on again yields the same error messages.

Any solutions for code 2?

We are experiencing some issues with the delta server at the moment. Unfortunately this isn’t currently reflected by the status page as we don’t have a separate item for that, but we are working on getting the status page and the delta server fixed as soon as possible!

The delta server should now be working OK. Let me know if you’re still experiencing problems.

I am still experiencing the same issue with error code 2

Could you try pushing an empty commit in order to generate a new delta?

A new push didn’t work. I am receiving the same messages.

Then I tried the following:

  • Changed to RESIN_SUPERVISOR_DELTA=0 so the device could get the most recent commit - that succeeded.

  • Then changed back to RESIN_SUPERVISOR_DELTA=1 and created a new commit - still fails with the same error messages

Hello @jeff – can you please paste here the Dashboard URL for the device and enable Support Access for a couple of days via the device Actions page?

@dfunckt All set. Support Access has been granted for

@jeff is that a development device? Do you mind if I stop your application for a bit while I’m looking into it? Do you have network bandwidth limitations (eg. cellular)?

Yes, that is a development device and has a broadband connection. Feel free to stop and restart the app as you need or reboot the device.

(I am located in Australia, which is why my response times have been slow.)

The device is fixed now and runs the latest commit.

I updated the device to the latest Supervisor (v6.3.5). That version is more resilient when applying deltas and can better identify and recover from rsync errors like the one you were seeing. code: 2 suggests the source does not match the source used for generating the delta. This could be due to SD card corruption BTW, and the fact it’s super-slow suggests you might want to use a better card :slight_smile:

Thank you for the fix! I will update my other devices to the latest Supervisor, as well.

I am not sure what you mean by a super-slow SD card as the device does not have one installed.

I couldn’t find a way to update the Supervisor on its own. Is this possible from our end?

Hi Jeff, sorry, currently the supervisor needs to be updated from our end. I’ve seen that you have a handful of 2.4.2+rev1 devices right? On those we’ve marked the supervisor to update to v6.3.5. That update will automatically happen within the next 24h (the device checks in for an update once every 24h - you can speed this up by rebooting the device and then 15 minutes after reboot a check is performed, so it should update then). :mantelpiece_clock:

Let’s see how this above works, and if you need any other devices to be updated just let us know! :exclamation: