Delta update server fails continuously


Yesterday i make update for my application (raspberry pi3). All devices connected yesterday receive update. But devices turned on today can’t get it.

Dashboard messages:

05.06.18 12:40:25 (+0700) Downloading delta for image ‘
05.06.18 12:40:44 (+0700) Failed to download image ‘’ due to ‘Got 500 when requesting image from delta server.’
05.06.18 12:40:45 (+0700) Downloading delta for image ‘
05.06.18 12:41:07 (+0700) Failed to download image ‘’ due to ‘Delta server is still processing the delta, will retry’


Hello, we’re aware of the issue and we’re deploying a fix. This was caused by a regression introduced in the latest deploy. We’ll get back to you as soon as the fix reaches production.


Seems, it works now


I tried turning on delta updates a couple days ago, but was getting this on my next push. I’ve had to turn them back off again.


Hi @jaquadro are you still seeing this?

Could you post the exact logs you were seeing, and the resinOS version you’re using?