Application refusing to update - rsync error


One of my app keep failing to update.
I’ve tried to redeploy multiple times and I keep having the following error.

Failed to download application '' due to 'rsync exited. code: 12 signal: null'

Hello there – disabling deltas, letting the device pull the update and re-enabling deltas afterwards should fix the issue.

However I wonder how this happened – what versions (resinOS/Supervisor) is this device on, was this a large update, and do you remember doing something out of the ordinary when this happened?

I had this issue today as well on Resin OS 2.3.0+rev1 (dev).

I’m working on another update and will see if a further commit generating a new delta will resolve the issue.

I can confirm that pushing another update didn’t fix the issue.

Had another issue with updates too on 1/3 devices on a delta update. A full update worked fine though.

22.12.17 23:04:51 (+1100) Failed to download application '**/**' due to 'Incompatible image'

How is that even possible? All the devices are the same…

I’m going to assume that the full update worked at that your devices are up-to-date, but still flag this as requiring attention from the delta’s point of view.