Does your EtcherPro fail to boot up? Here's what to do!

We have noticed that some EtcherPro devices fail to boot up and are stuck on the boot splash screen with the balenaEtcher logo. If you are an owner of an EtcherPro and you see similar behavior - this topic will have updates on how you can go about getting in touch, and fixing your device!

Good Looking forward to seeing if there is a solution, I do have that problem.

BETA solution (so far this solution resolves the problem)

  • Unplug the device from power
  • Plug an Ethernet cable (with a working internet connection) to your EtcherPro device. If your device does not have an Ethernet port, you can use a USB to Ethernet adapter plugged on any of the 16 USB ports
  • Plug the power cable to power on the device
  • The device should boot after a couple of minutes
  • Wait for 20-30 minutes for the device to automatically get the latest update
  • Unplug the power and the Ethernet cables
  • Plug the power cable back in
  • The device should boot without issues

Please let us know if these steps resolve the issue on your device.


@Ricardo1 let us know if the solution provided by my colleague solves your problem :point_up:

1 Like


Its working perfect now :slight_smile: already record first 30 micro sd :slight_smile:


Thanks for the confirmation @Ricardo1

Kudos to the EtcherPro team :slight_smile:

Unfortunately the solution above didn’t solve the issue on our side, is there any other possibility which we can try out?

Hello @Janine welcome to the balena community!

Could you please share more details? Do you see anything on the display? What is the behaviour following the soltuion step-by-step shared here? Does your EtcherPro fail to boot up? Here's what to do! - #4 by konmouz


We tried the steps provided above, left the LAN cable connected using a usb-> LAN for about 2-3 hours. We tried it several times, but the screen stays stuck with the Balena logo, see:

I have this exact issue and I have tried the Ethernet to usb port option and left it go overnight and came in today and unplugged it and removed the Ethernet adapter and nothing. This fix didn’t fix my issue what are my next steps.