BalenaEtcher Pro - Stuck on splash screen

My Pro device was working fine, then one day I came in and the screen was on the splash screen.
I tried removing all drives and power cycling, but it never gets past the splash screen.
Please advise on how to fix.
Thank you


Do you know the serial number of your device?

Where would I find the serial number?

Depending on the revision of the EP you can find it on the back of the device

Could it be S000503?

Hi, my colleague has had to log off for the day, perhaps if he has time he can check the device logs tomorrow. Meanwhile, could you please see if the instructions outlined in the following forums thread solve the issue you are experiencing? See: Does your EtcherPro fail to boot up? Here's what to do! - #4 by konmouz

Thanks, I will try this and let you know

Ok, I tired the steps and I still get the same results.

Hi @michig54,

Your device seems to be offline. Is it connected to power and previously connected to wifi?


It has never been connected to wifi. It does not have an ethernet port, but I used a USB to ethernet dongle to try the update to no avail. I can connect the dongle back in.

Hi @michig54,

Please connect your device to the internet using a USB to ethernet adapter. Check that the USB does have access to internet using a laptop. Then let me know.


OK I checked that the usb to ethernet works and it is plugged in.

@michig54 I don’t see the device coming up online. We need to do an RMA. Please send an email to store quoting this thread and we’ll take it from there.

I’ve gotten a new unit and have been using it for some time now, but the issue seems to be happening again. I will try the above steps again, but I am not hopeful.

I have been using an EtcherPro on and off for a few months now, but I walked into the office today and it was stuck on the splash screen, same as michig54s. I have tried power cycling it multiple times as well as the updating instructions found here. My device does not have a Ethernet port, so I used a USB to ethernet adapter. The adapter had internet (check with another device), and the switch lights were active when plugged into the EP, but after a few hours and multiple tries, it still boots to the splash screen and gets stuck.

Is there anything else I can try?

Hello! Let’s see if we can identify your device and possibly resolve the issue in balena cloud (remotely). Please send us an email at and we’ll take it from there :slight_smile: