Brand New EtcherPro Failing to Boot

I just received my EP unit today. It is failing to boot.

I plugged in the power – the LED screen powers up and it seems to start to boot. Then after a few seconds depowers itself. I have tried a couple of cables, in addition to the provided with the same results.

This unit is plugged into a 120 AC wall outlet.

Hi @rleugers,

I believe you’ve run into a known-issue with our EtcherPro units:

Can you try the steps shared there to see if it resolves the issue for you?

If it doesn’t please send us an email so that we can continue troubleshooting with you via email and provide an RMA replacement if needed.

I located and tried plugging in an Ethernet/USB cable. It is connected to the Internet.

The devices tries to boot for 2 sec then goes dark. I don’t even get a splash screen.

The unit is dead!

Emails are getting bounced trying again.

The unit is dead and requires an RMA.

Can someone help? I am about to contact the company who sold me the device for a return/repacement with them.

I need to get this unit working! It has been almost a week since last contact with support.

Hello @rleugers let me contact the Etcher Pro team to assist you!

Hello @rleugers , please contact us at with your order reference and device serial number (the QR sticker is located on the bottom of your device), despite the black screen it is possible for us to remotely reset your device and update it, thank you.

1 Like