Device showing as VPN online but unable to ssh in

Hi, I have a device [c30129d13da3fe0c5d5ec8c870052bab] (in a remote location) that has recently come back online after a prolonged disconnected period.

It is showing as “Online (VPN only)”, I have tried to connect to it from the CLI (which I believe doesn’t need the API connection to be working) and get the following error:

[Debug]   Trying to fetch device by UUID c30129d (string)
BalenaRequestError: Request error: tunneling socket could not be established, statusCode=500

BalenaRequestError: Request error: tunneling socket could not be established, statusCode=500
at Object.<anonymous> (/snapshot/versioned-source/node_modules/balena-request/build/request.js:190:27)
at (<anonymous>)
at fulfilled (/snapshot/versioned-source/node_modules/tslib/tslib.js)
at processTicksAndRejections (internal/process/task_queues.js:97:5)

For further help or support, visit:

My attempt to use the webbased diagnostics just gives the following error
An error occurred while querying checks data: Could not connect to device c30129d13da3fe0c5d5ec8c870052bab: HTTP/1.0 500 Internal Server Error

Are there any other steps that I can take to try to conect to the device and figure out what’s going on. (Support access is enabled if you need to have a look).

Many thanks.

Hi there, do you have any other balena devices connected to the same network as this device? And I know you said it is remote, but are you in contact with anyone that does have physical access?

Hi Ryan, thanks for the response. Unfortunately no it’s the only balena device on the network, as physical access is awkward. A physical site visit will be needed at some point anyway but as yet the timescale for that is unknown. If a fully remote solution is not possible (which I suspect will be the case) then it will just have to wait until then.

Hi, our engineers have tried connecting to the device but were only able to confirm the behavior you described earlier - the SSH tunnel did not work even though the device was connected to the VPN - there was unfortunately no way to do any form of remote-only debugging. I can see the device went completely offline shortly after that, I assume that means we have to wait until it is physically collected. Is there anything else we can do for you in the meantime?

Thank you for looking, no that’s it thanks.