Device is always inactive

Hi,

I am trying to follow the Getting Started with Raspberry Pi 4 but the device is stuck in an ‘inactive’ state.

.

I’ve checked some similar posts but none of them could help me solve the problem.

  1. The device is connected over wifi.

  2. I can balena ssh into it from another device in the same network.

  3. Below are logs for resin-supervisor, openvpn and dmesg

    https://pastebin.com/wsTnJpex

    https://pastebin.com/mmWXmGSi

    https://pastebin.com/vV1a3i0g

  4. Below is the summary page of the device on dashboard and I’ve granted support access.

    https://dashboard.balena-cloud.com/devices/b8b85d8855c3465f9b2576eb8ded239c/summary

Any help is appreciated!

Hi @jacques7zhu,

Welcome to the forums!

It seems like the device cannot establish a VPN connection. I can’t determine the exact reason, because the lines in vpn logs are truncated, but it seems like a TCP connection could be established but, after that the connection fails. I can’t find any indication, that the device reaches our cloud system though, so it seems like the connection is probably intercepted somewhere on the way. Maybe there is a firewall trying to perform deep packet inspection on that network?
When you write you can access it from another device on the same network, do you mean your Laptop or another balena device on the same network? If there is an online balena device on that same network could you grant us support access and point us to the device, then we can also access the non functioning one and dig deeper.

Hi @afitzek,

Thanks for your reply.

I am using a network in the company but I am not sure whether there is a firewall. However i tried yesterday with my personal wifi without any firewall and the device kept inactive. b.t.w I am in China, does it affect the connection?

By saying that i can access the device from another device, i mean my laptop. I have another Raspberry 4 on hand and i’ll try with it.

Hi,

Being in China might affect the connection, since our VPN servers are located in the US, so the big firewall might intercept the connection and try to inspect it. We cannot guarantee functionality in this case unfortunately, but this is probably the cause of the problem. Please try it with another device as well and from different networks.

I tried with another Raspberry Pi 4 and it’s the same result. I will try deploying an openBalena server then. Thanks though.