Debugging disconnected machine

I am having an issue with running balenaOS on the customer site. I already setup several devices at my site without any problems and they always show up in the balenaCloud almost immediately. However, the same setup in the customer network does not show up in balenaCloud. Here are some details:

  • I’m running balenaOS in a docker container (from balenaos-in-container ) balenaOS 2.95.12+rev1, on x86_64 ubuntu host - the same setup worked fine for same machines on my local network.
  • The device is online (as connected to the internet), I can ping google from it, upload data to AWS from it, etc.
  • I don’t see any errors from the balenaOS in the logs.
  • The documentation about Network Requirements say some more details, but I am not sure how to exactly interpret it and apply in my specific situation. Ideally, I would like to confirm or disprove that it is because of some sort of firewall on the customer site. Unfortunately, I do not have any way to access or control their firewall - but it does not seem very restrictive as I can easily access other sites.

Do you have any suggestions on how to debug this, where to look for some logs or what commands can I run on the machine to better understand the problem and/or network restrictions in the target site?

can you ping from the device connected to the customer’s network. It sounds like there is either some DNS or firewall issue at hand.

firstly, confirm that the machine is connected to network. check the network settings, IP address, subnet mask and default gateway to ensure they are configure correctly. You can also trying ping the machine from another device on the same network to check if it repond.

Furthermore,also access the network settings on the machine to ensure they are configured correctly. for window go to control panel ->network and internet-> network and sharing-> and check the network status and connection properties.