Could not find a secondary wireless device

I’m trying to make my Pi work as a repeater. I was following along with the tutorial on Balena’s website and things were going very smoothly.

The Pi had connected to the BalenaCloud and started updating. at 79% I received this error “Could not find a secondary wireless device. Exiting…”

After a few minutes, the device went offline and I haven’t messed with it since.

I have an Amazon wifi dongle plugged into it, it seems to be having some sort of issue finding it. Does anyone have any suggestions, or should I send this wifi dongle back and try another?

Any and all help is appreciated, this is all VERY new to me.

Hello @PineAppleCawks first of all welcome to the balena community.

Could you please confirm what Pi are you using and the application that you are deploying?


Morning mpous! and thanks for taking the time!

I have been following along with this tutorial On there it directed me to the wifi-repeater project from Balena github here

The Pi I have is a 3 labeled as model B+. I have noticed that the Raspberry Pi 3 “device type” option says something about those models not having 5 GHz. However, my model has 5 GHz, so I assume it is the pi 3 (64bit) device type. I must mention that I have tried both options and received the same result though.

When it appears in my dashboard I get the following sequence of events:

-Online (heartbeat only)
-Switches over to “updating” and a progress bar
-5-7 minutes pass, a yellow exclamation symbol pops up and says “VPN Disconnected” if I hover over it
-Somewhere around 75% on the update It hangs up and no more progress is made
-I click into the device and see the following

" wifi-repeater – WiFi repeater: starting…
wifi-repeater Wireless interfaces found: wlan0
wifi-repeater Wired interfaces found: eth0
wifi-repeater Creating WiFi AP on wlan0 with SSID “WiFi Repeater” and password “charlietheunicorn”…
wifi-repeater Ethernet device has no internet. Attempting to use secondary wireless device to connect to WiFi…
wifi-repeater Could not find a secondary wireless device. Exiting…"

At this point the Pi has created a visible wifi network that I can log into using the above password. However, it has no internet access. The terminal is unavailable and any actions I take in the device “Summary” page do nothing.

I have attempted to reflash the SD quite a few times and changed the variables inside the “add device” page. I have tried two different dongles. All attempts have ended in this result.

I am thinking I might just try and restart from the very beginning of the tutorial as I have just been restarting from the point that I click “Add device” on the Balena dashboard with no luck.

Anyway, thanks in advance for any, and all input!

Well, I don’t have a definitive answer as to how the problem was solved.

I deleted everything and started from scratch. Now things are working perfectly. I have run into a separate issue but will start a new thread for that.

thanks again!