New device always offline after the initial connection to balena cloud

Hi, I am trying to setup a wifi repeater using a Rasberry Pi 3 B following this tutorial:

After the initial connection to the balena cloud (which I assume shows that the wifi credentials are defined correctly), the device shows up as offline:

The AP wifi is created and I can connect to it, but there is no internet.
I have tried both production and development images.
I have tried to ssh to it but it times out. It shows up in my router list of devices after the initial connection but seems to be disconnected from the router afterwards.
Thank you in advance for your help!


Can you share more about your setup?

According to the article you linked:

Thanks for the response. Yes, I do have a wifi dongle connected to the raspberry pi (the raspberry pi 3 B has a built in wifi too). And I just checked the dongle on my laptop to make sure that it works.

Hey @rezafateminasab, have you tried with the Raspberry Pi wired to your router? This might help identify whether both the WiFi connections are working as expected. The onboard WiFi should become the access point, and the dongle should connect to the cloud. If the dongle isn’t detected or the required environment variables aren’t set you might see only one of the connections working.

Did you set the 4 required variables in the dashboard before it connected the first time?

AP_SSID Access point network name Wi-Fi Repeater
AP_PASSWORD Access point network password charlietheunicorn
WIFI_SSID Wi-Fi network name None, only required for Repeater mode
WIFI_PASSWORD Wi-Fi network password None, only required for Repeater mode

Thanks for the response! I ended up setting up the wifi repeater using the raspios, so I no longer can check. But for others, you might be right about one point: I was mistaken about what wifi module connects to my current wifi and which one makes a new wifi, so that might have been the problem. Anyway, thanks again for your response.