Balena Locating for managing BLE devices on a raspberry pi Problems

Hello. I’m new to this forum, so not sure if I’m posting the correct place.
I want to make a “gateway” for BLE beacons, and a quick google search led me to this post:

I’ve followed the guide very carefully, and everything works until I get to the part where
I go to the public device URL. It takes a very long time to load, and i have to refresh often.
And most of times it fails to load.

But when it do work I don’t see any devices. However on my phone I’ve used a scanner app, and
there I can easily spot a lot of devices.

I’ve tried different versions of BalenaOS and also tried on a RPi3 instead of a 4. And getting the same results.

Does anyone have some goot tips to try out?

Greetings from Morten, Denmark

Hi Morten, and welcome to the Forums. And, you posted in a perfect place. :slight_smile:

I myself am not too familiar with that project, but @phil-d-wilson sure is! Let’s see if he can chime in with some thoughts or ideas. It is late night for him, and heading into a weekend, so it may be a few days before he gets this ping however. :first_quarter_moon_with_face:

When the device is loading the Public URL and rendering the UI, do any logs appear in the balenaCloud dashboard? Any errors, timeouts, or other notable items getting captured and logged there?

Also, one other thought, the SD Card… Is it a high quality, fast SD Card? It is often overlooked, but they can have a major impact on performance when using small single board computers like the Raspberry Pi and similar. Let us know, thanks!

Hi.

Oh that’s good to hear :slight_smile:

Perfect. I will be great to hear what he has to say.

Yes it does give this message: “Microsoft.AspNetCore.HttpsPolicy.HttpsRedirectionMiddleware[3] dashboard Failed to determine the https port for redirect.”

I’m using a Sandisk Ultra A1 128GB card. So it should be ok :slight_smile:

Thanks for the help.

Morten

Hey @Morten

I’ve just run the project up on a Pi4, and the dashboard loads within ~2 seconds and seems to work fine.

The “Microsoft.AspNetCore.HttpsPolicy.HttpsRedirectionMiddleware[3] dashboard Failed to determine the https port for redirect.” is not an issue, it’s a normal warning about HTTPS redirection.

Did you use the same SD card each time you tried with different devices? It could be the card causing the performance slow down.

Phil