Connection refused unknown host.

Hello, so i just tried to setup an minecraft server using balena os on my rpi4. I managed to get it to appear on the dashboard it’s active,online. I followed this tutorial : How to create a Minecraft Server for the Raspberry Pi 4 with balena . The rpi4 is connected to wifi, and my main pc is connected by ethernet and i am using Pop_os.
I can ping the host from my pc and from other devices and can ping back. I tried connecting via ip address and still connection refused.
When i try to ssh into the host from my laptop it says ssh : connect to host port 22 : connection refused. Is something blocking the port ? then i found this comment section Help with minecraft server project - #12 by garethtdavies tried the curl command and it gives back this : curl: (7) Failed to connect to port 80: Connection refused

Please keep in mind, I am completly new to this, if this question has been answered somewhere else please post the link and il delete this post.Thank you !:slight_smile:

Hey there @disco211 and welcome to the forums.

Could you help us to understand what you’re trying to do? A device as you’ve set it up would not be running an SSH daemon on port 22. As you’re running a device with a development version of the OS, you would be able to use SSH to connect to the hostOS on port 22222, with something like ssh root@ -p 22222. Note that this would only connect you to the host OS of the device though, not the Minecraft server container.

Looking at the screenshot you provided (thanks!) I can see that it looks like you don’t have a release built, and so although the device is online and running, the Minecraft server app isn’t actually installed on there.

If you go back to balenaHub and click the Deploy with balena button, it will take you back to the dashboard and open up a window to ‘Create and deploy to application’. Note that there’s a link at the top that says ‘Use an existing application instead’ (see below) - use this and choose your existing minecraftserver application. This will start a build of Minecraft and deploy it to your Pi 4 as soon as it’s ready. You can see the status under Releases under the application.

Hi, I would like to follow up on this, were you able to solve the issue without our assistance or is there anything else we can do to help you?

Hello! Thank you for the replies. I didn’t look into the project for the past few days I have been busy with other things. I will comeback with a concrete result in a few days. I will try to do everything from scratch and i will reply to this post :slight_smile: