Help with minecraft server project

Hi, I just tried running this project.

All seems to be running OK…

I just get this error when trying to access it from a mac running Minecraft Java edition.

“io.netty channel.AbstractChannel$AnnotatedConnectException Connection refused”

Pi is plugged into my router
Firewall is turned off on my laptop

I can’t figure out where the problem is and how to solve it. Any tips would make my daughter very happy. Many Thanks

		    _.-(6'  \
		   (=___._/` \
		        )  \ |
		       /   / |
		      /    > /
		     j    < _\
		 _.-' :      ``.
		 \ r=._\        `.
		<`\\_  \         .`-.
		 \ r-7  `-. ._  ' .  `\
		  \`,      `-.`7  7)   )
		   \/         \|  \'  / `-._
		              ||    .'
		               \\  (
		                >\  >
		            ,.-' >.'

Hi there, the first thing to try would be to see (assuming you are using the default hostname balenaminecraftserver) if this is resolvable from your client. You can try pinging it to see if it responds. Ideally you should try to do this with both devices on the same network segment (i.e. same Wi-Fi band or Ethernet VLAN).

In addition, you could also try to connect via the IP address directly - you can find out what the IP of the device is from the dashboard.

Hi thanks for the reply. No problem pinging it.

PING balenaminecraftserver.lan ( 56 data bytes
64 bytes from icmp_seq=0 ttl=64 time=13.458 ms
64 bytes from icmp_seq=1 ttl=64 time=16.714 ms
64 bytes from icmp_seq=2 ttl=64 time=1.088 ms
64 bytes from icmp_seq=3 ttl=64 time=122.251 ms

Not sure what to do next. Thanks

Can you try to connect via the IP address directly with the MC client? Do you get the same error message? Is there any output in the server/dashboard logs?

You can also try installing a telnet client on the mac and then run:

telnet <port>

where <port> is either 25565, 25575 or 22 (try all of them to see if you get a socket connection) to see if the server is actually reachable over TCP.

Ah thanks port 22 seems to work. Not sure how to use that to help get onto the server through minecraft though


If you can’t get to port 25565 and 25575, that means something is blocking communication between your mac and MV servers. You can test this by opening a web terminal connection to the host container on the device and running curl 25565 as well as curl 25575`. You should get a response if the MC container is running. If so, then you will need to check the network path from your mac to the MC server to see what is blocking these higher numbered ports…

Port Scanning host:

 Open TCP Port: 	22     		ssh
 Open TCP Port: 	22222

Port Scan has completed…

Thanks all very useful. I have no idea what is blocking the ports but its a good lead.


Only problem is I don’t know where its blocked and how to unblock it. Is the laptop, minecraft software, router or raspberry.

Thanks for the help.


Hi are you able to log into balenaCloud and see the device online and see that all the services are running? If so can you try what Anton suggested above and open a web terminal to the host container on the device and running the curl commands to ensure the mc-server container is functioning correctly? We should probably rule out that everything is functioning correctly first before trying to debug any network issues. Also, can you confirm the model of Pi you are using, as I note that the instructions say the 1GB variant will not work.

Hi Gareth thanks for the reply.
Its a 4GB Pi 4 so should be good.

I am not super familiar with the Balena cloud environment but the only error I can see is this.

21.04.20 22:19:34 (+0100) mc-server Error: Invalid or corrupt jarfile paper.jar

Just tried this too using Terminal MC server
root@balenaminecraftserver:/# curl 22
curl: (7) Failed to connect to port 80: Connection refused

But I can see through my mac network utility that its connected but only port 22 and port 2222 are open.

Any ideas welcome

Thanks for your help.

Must have been that java file. Maybe I tried to insall it before it had updated. Just redid the whole thing working now. Thanks :slight_smile: