Minecraft Server Raspberry Pi 400

I have been trying to setup a minecraft server in my pi 400 using balena cloud. Everytime i try to use balena push to push the server to the Pi i get an error that i think it’s not supported on the pi 400?
My raspberry Pi is connected to the network using ethernet.

I used the latest version(1.1.1) from here:

I also had tried the version 1.1.0 but i am getting the exact same issue
For BalenaOS i am using balenaOS 2.65.0+rev2
Any other information i can provide to fix this issue?


This is indeed strange. It should be supported as it’s basically the same as a Raspberry Pi 4. And that is supported for sure. Maybe there’s an issue with generating the images for that. I’ll take a look

Can you try something? Download the minecraft repo, and edit the Dockerfile.templates that are there. Instead of %%BALENA_MACHINE_NAME%%, replace it with raspberrypi4-64

Keep everything else the same, and push it to the same app using balena push from the CLI

I tried that for every Dockerfile template with raspberrypi4-64 and it did work but i had other weird issues with the server later on not starting for unknown reasons which was probably something on my end but i couldn’t figure it out and i gave up on it and used a completely different method to host an mc server.

But for other Pi 400 users that will go with this replacing the %%BALENA_MACHINE_NAME%% with raspberrypi4-64 in every template file does seem to fix it. Thanks for the help

Hey, sorry to hear you had trouble getting the MC server working on your Pi400. We are still in the process of releasing base images for that platform but as mentioned above the Pi4 images would be compatible since they are the same architecture.
What were the other server issues you were seeing once you changed the BALENA_MACHINE_NAME? Anything we can help to investigate?

The other issues wasn’t with balena it did upload it successfully after fixing that but when it was trying to start the server there were unknown issues saying something like the server file is corrupted and other weird stuff which this isn’t an issue with balena but an issue with the github project as a lot of people have reported there the same issue that own a Pi4