Balena Minecraft Server Online Multiplayer

Hello I have a Raspberry Pi4 8GB, server is set to 6GB and plugged in with a cat6 cable to my router. I’m a noob but followed this guide and was able to figure out my way through the whole thing.

I set up the No-IP account, went through their setup instructions, port forwarded the propper port on my router, and checked it via open port checker. Its green so all is good there.

I set my server to the No-IP address I set up and I can log in fine sometimes and sometimes it times out. I cant have multiple people log in while I’m logged in either, they get timed out. This is what we’re seeing.

Faild to connect to the server
io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection timed out: no further information:

Possible issue I see this after restarting the server
[17:17:06 WARN]: Unable to determine local host IP, please set server-ip in server.properties
also
[16:32:14 WARN]: Can't keep up! Is the server overloaded? Running 5044ms or 100 ticks behind

Another potential issue I see is the wifi is constantly trying to connect even though I’m hardlined.
28.02.21 12:24:09 (-0500) wifi-connect Checking internet connectivity ... 28.02.21 12:24:09 (-0500) wifi-connect Your device is already connected to the internet. 28.02.21 12:24:09 (-0500) wifi-connect Skipping setting up Wifi-Connect Access Point. Will check again in 120 seconds

Any help would be greatly appreciated.

Hey there @xpacerx welcome to the forums. Let’s ping @AlexProgrammerDE on this one; he’s the author of this project and is usually around here so he may be able to help with this!

Thank you.

Thats normal actually.

I’ve never seen that cause too much trouble.

Looks kind of suspicious, but shouldn’t cause your issue.

I think it might be something with your port forwarding. Can you confirm your forwarded 25565 on your router and chose the “TCP” protocol?

I’m pretty familiar with port forwarding process on my router. 100% certian the port 25565 TCP is being forwarded. I even checked it on the port checker site No-IP had me test and it connects fine.

Your ISP/Router/Firewall is not blocking port 25565.

Hey there,

Here’s a handy link to our documentation on WIFI setup: Network Setup on balenaOS 2.x - Balena Documentation

Phil

@phil-d-wilson thank you for the link, I found it easier to just stop the wifi-connect service in the dashboard.

@AlexProgrammerDE I did some more testing and was able to get my son on at the same time as me but not my daughter. The only way I was able to get my son and me on at the same time was logining into the local using balenaminecraftserver then my son used the No-IP address. My daughter could not see the server or connect with either while we were on.

I noticed that any time I connected to the server locally it was my local pc ip address plus a random port number but any time I connected through the No-IP address it was always connecting through my default gateway ip address with the port 25565. It was never connecting through the public ip address Balena assigns in the server. Is that normal?

I havent got any feed back to this yet so I’m searching as best I can for potential problems. Is there any tests I can do or some specific info anyone needs to be able to help me with this?

I was looking at the balena-rcon terminal and I get this when I first start it up. but it ends up connecting after that.

Connecting to b4dd74b58bd50e25e8653d04c8b8abc0…
Spawning shell…
Connection failed.
Error 111: Connection refused
root@pacecraftserver:/#

Also in the mc-server terminal window I see this over and over

Connecting to b4dd74b58bd50e25e8653d04c8b8abc0...
Spawning shell...
root@pacecraftserver:/# Disconnected
Connection error
Reconnecting...
Reconnected

Hi there, the terminal connection errors are unusual and are usually due to underlying device connectivity (outbound) to the Internet, since the web terminal runs over a VPN connection we create back to our VPN server pool.

Are you able to see the device on the balenaCloud dashboard and observe whether it’s dropping off periodically? Are there any signs of memory/CPU pressure (also on the dashboard).

Can you run a ping session to your device from another local machine on the network to see if the device is losing LAN connectivity or it’s just WAN. Perhaps try a different port on the router or switch to WiFi connection to start ruling things out.

If general network connectivity is unstable, this will almost certainly cause the MC issue you are experiencing.

More specifically to the port forwarding issue, you can try an alternative option using ngrok.

Hi, thanks for your reply,
I realized the terminal connection errors were when I unplugged the network cable to from the RPi to test them.

I tested my cat6 cables with a cable tester and they were fine. I also tried another port on the switch and even plugged it directly into the router.

I can see the device in the balenaCloud dashboard the CPU is -14° which is in the green. The RAM almost max out shortly after reboot. I have the RAM set to 6GB and it gets up to around 5.3GB and stays there even with me not logged in.

this pops up in the log after reboot

[02:07:17 WARN]: Can’t keep up! Is the server overloaded? Running 5029ms or 100 ticks behind

I pinged the local IP and the public IP and both were fine.

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 1ms, Average = 1ms

I skipped the step on setting up the wifi since I wasnt going ot use it. I looked at setting up the wifi on this page but it I cant find the /system-connections/ folder when I use winSCP to look through the files.

I have set up a .net address through No-IP which I tested the port 25565 and its open. I can also connect to the server through that address.

Your ISP/Router/Firewall is not blocking port 25565.

I only got 2 people on at once but it was through several time outs and failed logins. It was kind of a fluke. Usually only one person can get on and everyone else just times out even though they can see the server.

On my server, this is the same but it doesn’t mean much. All it means is that the server is struggling to keep up but it does not affect anything else to my knowledge.

I have same problem with wifi-connect

How to stop this?

wifi-connect Checking internet connectivity …
wifi-connect Your device is already connected to the internet.
wifi-connect Skipping setting up Wifi-Connect Access Point. Will check again in 120 seconds

If I just click on the wifi-connect’s stop button on the dashboard it will stop the service only for the currect power cycle. When I turn on device again the wifi-connect starts again too.

I’ve also tried to set up a ACTIVITY_TIMEOUT device service variable to value 120 but it seems it doesn’t work.

Can anyone help?

Same issue here but in my experience, it doesn’t do or change anything in the way the server runs.

Of course but the console clogs up

In my experience everything you need to know (e.g plugins and loading) are shown before the WiFi connect starts. Since I haven’t used the platform for a bit the I’m a bit rusty but I’m pretty sure you can filter the logs if you want.