Cannot connect Raspberry Pi to my fleet

I created a 2 new fleets(One for Raspberry Pi4 and One for Raspberry Pi3 and have been trying to add a Raspberry pi to it for a few days now.
I have tried:
3 different flash cards
2 different wired network connections on completely different networks
3 different wifi networks
2 different computers for flashing the cards
2 different Raspberry Pi4’s connecting to the RPI4 fleet
1 Raspberry Pi3 connecting to the other RPI3 fleet.
All 3 version of the Balena OS listed in the Dropdown.

In most cases the device is on the network and I can connect to it over ssh. But everytime it shows messages like the following:
Feb 27 04:09:43 75ea157 balena-supervisor[50258]: Cannot connect to the balenaEngine daemon at unix:///var/run/balena-engine.sock. Is the balenaEngine daemon running?
Feb 27 04:09:43 75ea157 balena-supervisor[50277]: activating
Feb 27 04:09:43 75ea157 systemd[1]: balena-supervisor.service: Control process exited, code=exited, status=3/NOTIMPLEMENTED
Feb 27 04:09:43 75ea157 systemd[1]: balena-supervisor.service: Failed with result ‘exit-code’.
Feb 27 04:09:43 75ea157 systemd[1]: Failed to start Balena supervisor.
Feb 27 04:10:00 75ea157 balena-supervisor[50319]: Cannot connect to the balenaEngine daemon at unix:///var/run/balena-engine.sock. Is the balenaEngine daemon running?
Feb 27 04:10:00 75ea157 balena-supervisor[50328]: Cannot connect to the balenaEngine daemon at unix:///var/run/balena-engine.sock. Is the balenaEngine daemon running?

Any thoughts on what I should try next? I have successfully joined a few devices to a previous fleet but that was about a year ago.

Hey @ngelotte welcome to the forums and thanks for sharing this issue!

Have you managed to make any progress here? I’m looking at it now and am able to reproduce similar issues using a Raspberry Pi 3 with balenaOS 2.108.18+rev1. I’ve plugged in a monitor to the device and can login and see that balenaEngine is not starting. I’ll continue to look into it and report back my findings.

Hey guys, I’m also interested in the solution since I’m having a similar issue here: RaspberrPi Zero 2W not showing up in balena cloud dashboard

Can you guys confirm how you’re downloading the image and flashing it? Are you using the ‘Flash with Etcher’ process, or downloading and saving the image file then flashing it, using Etcher or some other tool?

As a follow up, from my side it seems that I only encounter problems if I use the ‘Flash [with Etcher]’ button. If I download the balenaOS image and then select the downloaded file manually within Etcher and flash that way, it seems to work fine.

1 Like

Yes I used the Flash[With Balena] option every time. I just downloaded the image and flashed it and it worked!!

Thanks for your help. Do you want me to collect any logs around why the Flash[With Balena] options is creating a slightly wrong image.

hello @ngelotte

I have a solid hypothesis on what’s happening and made a patch.
Unfortunately, I couldn’t reproduce the issue here to confirm it works.
Would you try this pre-release version of etcher and confirm it works?

Hello, had the same issue today. I can confirm that flashing the file worked for me also.

I got a 404 on your link.

Hello, the correct URL should be: Release fix-accept-encoding-gzip · balena-io/etcher · GitHub

please let us know if you notice if downloading+flashing with Flash with Etcher is faster now too

I downloaded the Zip from Github. But I am not sure what to do with it. It does not seem to contain an EXE file like my installed version of BalenaEtcher.

If you can let me know what to do with the downloaded zip, I will test it out.

I confirm that using the option “Download BalenaOS image” instead of “Flash”, and then flashing with Etcher, it works!

The latest release of Etcher should resolve the “flash with Etcher” issue. Release v1.18.4 · balena-io/etcher · GitHub

can confirm, the latest version of Etcher fixed it for me too!