Booting Beaglebone Black failing

sdcard
beaglebone

#1

I have just created an account and I am trying to get up and running with a BBB, I successfully added a RPi 3 yesterday but we are changing platforms to the BBB.

I have created an app and downloaded the image from the Add a new device window for the BBB.
I have written it to the SD card using BalenaEtcher but when I load it into the BBB it is throwing an error then reverting to the eMMC.

The card is new and was used for the RPi so is known to be good, Etcher verifies ok. I have tried redownloading the image but I get the same result:


U-Boot SPL 2015.10-00001-g143c9ee (Nov 06 2015 - 15:27:19)
bad magic


U-Boot 2015.10-00001-g143c9ee (Nov 06 2015 - 15:27:19 -0600), Build: jenkins-github_Bootloader-Builder-274

       Watchdog enabled
I2C:   ready
DRAM:  512 MiB
Reset Source: Global external warm reset has occurred.
Reset Source: Power-on reset has occurred.
MMC:   OMAP SD/MMC: 0, OMAP SD/MMC: 1
Using default environment

Net:   <ethaddr> not set. Validating first E-fuse MAC
cpsw
Hit any key to stop autoboot:  0
gpio: pin 53 (gpio 53) value is 1
switch to partitions #0, OK
mmc0 is current device
gpio: pin 54 (gpio 54) value is 1
Checking for: /uEnv.txt ...
Checking for: /boot.scr ...
Checking for: /boot/boot.scr ...
Checking for: /boot/uEnv.txt ...
** Invalid partition 4 **
Failed to mount ext2 filesystem...
** Unrecognized filesystem type **
Failed to mount ext2 filesystem...
** Unrecognized filesystem type **
** Invalid partition 7 **

Any ideas where I can go from here?


#4

OK I need to learn to RTFM. When redownloading the image again I read that I have to hold the button to flash it to the eMMC - I had assumed it was booting from the SD card and when seeing the errors just assumed it was an image/write problem.
Held the button on boot and, lo and behold, it has sprung into life.


#6

Glad to know that you made it work.