basicstation offline

I have been having issues for the last few weeks trying to get my Raspberry Pi based LoRaWAN gateways online.

Currently, I have a RPi3 based gateway running basicstation that I can talk to locally via HDMI and USB keyboard but which isn’t showing as online in the balena dashboard

I try logging in locally as root and typing ifconfig to see if the wlan0 device has connected to my local LAN but find it has an IPV6 address.

Any debugging advice appreciated as I’m about to the promote The Things Network in my community (schools, etc.) but I must have stable gateways first!

I should say until recently (a few months) I had three RPi gateways working excellently running Balena for years.

This device was working via a RJ45 connection 8 days ago. But I now need it to work solely on WiFi.

This local gateway (Clare, Ireland) set-up is:
Type: Raspberry Pi 3
Host OS version: balenaOS 2.107.10,
Supervisor version: 14.4.4
WiFi connection to router (not being seen by router or by root shell “ifconfig wlan0”).
Running basicStation (armv7hf Created Mar 4th 2023, 9:23 PM)

I should also say that my remote gateway (Mayo, Ireland) is working fine still. Its set-up is:
Type: Raspberry Pi 3 (using 64bit OS)
Host OS version: balenaOS 2.107.10,
Supervisor version: 9.15.7
RJ45 connection to router.
Running basicStation (aarch64 Created Apr 7th 2021, 7:17 PM)

So my current assumption is that I haven’t set up WiFi properly for basicStation.

If I look at the microSD card on my laptop I see “resin-boot” mounted as E: and directory
Has a “balena-wifi-01” file. Whose listing is:






But if I put this microSD card in my Rpi3 and boot up and login locally as root I don’t see this file in the /resin-root/system-connections directory.

Huh? Where did it go?

So I found this post:

And so added ,“country”:“IE” to the end of my config.json file by editing it on my laptop. Then replaced the microSD card in my device and rebooted.

It now shows the four green LED flashes of death after a few minutes and repeats. Even after 10 minutes there is nothing seen on Balena Dashboard for this device.

And if I check if my local WiFi router has seen the device (I knows its MAC address) I see no entry.

Also I have now lost the ability to login locally to the device as root.

So tried latest OS code on a different device, a Raspberry Pi 4. I got this to talk with the Balena Dashboard when it had a wired RJ45 connection to my router but not when just over WiFi.

Type: Raspberry Pi 4 (using 64bit OS)
Host OS version: balenaOS 2.113.4+rev1
Supervisor version: 14.9.1
RJ45 connection to router works by WiFi doesn’t
Running basicStation (aarch64 Created Apr 7th 2021, 7:17 PM)

I have a local root login but I don’t know how to debug the WiFi. I added “country”:“IE” to config.json and added two newlines to the end of balena-wifi-01 but hasn’t fixed lack of WiFi connection.

I’ll just keep trying things I find on page:

After much experimenting I found using my local root shell and the “nmcli device wifi”.

I found that the problem was my home WiFi uses a space in its SSID and a ! in its password.

If I create a 4G hotspot on my mobile phone with SSID balena and password 2023balena then I can connect using:

root@ef62bdo:~# nmcli device wifi connect balena password 2023balena

I get a connection and the device can be seen on Balena Desktop.

(PS. I’ve tried using double quotes around the SSID and password but it didn’t help)

1 Like

@kilnageer apologizes for the long delay answering your message and glad to see all of your messages fixing your problem (related with your modem)!

Could you please confirm that everything works as expected?

Let us know if we can help you more!