RAK2445 GPS Troubleshooting

I have Pi3 and RAK2245 configured as a Balena Basic Station. It is communicating with The Things Stack. I get the error “[S2E:INFO] Beaconing suspended for 10s - insufficient GPS data: time position”. I moved it outside, but I still get the error. Can I use the Host OS or basicstation terminal to troubleshoot the GPS? Where can I find a list of commands for GPS troubleshooting?


Hello @jmpratt thanks for your message.

As far as i know, GPS was not working on basicstation. I have some questions for you:

  • do you have a GPS antenna connected to the RAK2445? Does it have visibility to the sky?
  • What basicstation version are you using?
  • Why do you need GPS?

Let’s stay connected!

Hi @mpous. You bring up some good points. I don’t need GPS. My basicstation is running balenaOS 3.0.16. I need to focus on getting my Lora node to communicate with my gateway.

I am using a Heltec ESP32 Lora v2 for my node. I have tried MicroPython and Arduino projects on Github. Neither seem to be working correctly. Do you have any recommendations on which language or project to use?


@jmpratt could you please share more logs of your basicstation gateway?

@mpous, sure. Which logs do you want? The Balena Cloud log or the TTN Gateway log? They both show the basicstation working and connected to TTN but no data is flowing. I don’t have any active nodes transmitting to the gateway.


@jmpratt i meant the balenaCloud logs of the basicstation service! Thanks

Sure. Here is the log:

balena-basicstation_silent-star-2023-07-26t11_08_38+00_00.txt (137.9 KB)

Could you please deploy this app on your device?

Done! Here’s the log after deploying the app:

balena-basicstation_silent-star-2023-07-26t23_55_18+00_00.txt (130.9 KB)

Ok @jmpratt i see this

Beaconing suspended for 10s - insufficient GPS data: time position

2023-07-26T22:49:54+00:00 <basicstation> 2023-07-26 22:49:53.839 [SYN:INFO] MCU/SX130X drift stats: min: +1.0ppm  q50: -4.8ppm  q80: +7.6ppm  max: +8.6ppm - threshold q90: +8.1ppm

2023-07-26T22:49:54+00:00 <basicstation> 2023-07-26 22:49:53.839 [SYN:INFO] Mean MCU drift vs SX130X#0: 3.9ppm

2023-07-26T22:49:55+00:00 <basicstation> 2023-07-26 22:49:55.337 [S2E:INFO] Beaconing suspended for 10s - insufficient GPS data: time position

2023-07-26T22:50:05+00:00 <basicstation> 2023-07-26 22:50:05.337 [S2E:INFO] Beaconing suspended for 10s - insufficient GPS data: time position

2023-07-26T22:50:06+00:00 <basicstation> 2023-07-26 22:50:06.440 [SYN:VERB] Time sync rejected: quality=114 threshold=113

2023-07-26T22:50:12+00:00 <basicstation> 2023-07-26 22:50:12.741 [SYN:VERB] Time sync rejected: quality=115 threshold=113

Could you please confirm what balena device Type are you using for your Raspberry Pi 3? is this the 32 bit or the 64 bit? Usually this issue is a nightmare so let’s try to explore if the device type can affect it.


@mpous I’ve attached a more recent log. The Beaconing suspended messages no longer appear.
balena-basicstation_silent-star-7-27.txt (145.0 KB)

The device type is Raspberry Pi 3, 32 bit.

Is it working well now?

El dj., 27 de jul. 2023, 13:48, Jason Pratt via balenaForums <notifications@balena.discoursemail.com> va escriure:

I appears to be. TTN shows regular status messages from the gateway.

Is there a command I can use in the terminal window to see if the GPS is tracking? Or does this newer image just use network time vice GPS for beaconing?

Basicstation didn’t use gps some months ago.

El dj., 27 de jul. 2023, 17:29, Jason Pratt via balenaForums <notifications@balena.discoursemail.com> va escriure:

I think my gateway is up and running but I have one more question. Should I be concerned about this message:

2023-07-28T00:58:20+00:00 basicstation 2023-07-28 00:58:20.260 [S00:DEBU] [CRC FAIL] 904.900MHz -11.75/-111.0 SF7/BW125 (mod=16/dr=2/bw=3) xtick=089c5fb4 (144465844) 223 bytes: 390B45D81D24DC3617294FC181A8EBB043ECB67921F280026C5E36832DB261089744346484EAB0F0EF89C76B87722B654F2A787505E09C545D46ECAD3BD069EA…

I don’t have any nodes transmitting. Is this the gateway receiving bad LORA packets?

1 Like

That’s a possibility. Maybe your gateway is receiving packages from other LoRa nodes and forward them to TTN.

Does the CRC FAIL indicate that my gateway is receiving a LoraWAN message but the message is failing the CRC check?

Mmmm maybe this is a message for another lorawan network catched by your gateway? Does this make sense?

El dv., 28 de jul. 2023, 20:44, Jason Pratt via balenaForums <notifications@balena.discoursemail.com> va escriure:

If it has CRC errors it will not forward it to any LNS