BalenaSound is not installing on my raspberrypi

I am trying to install balenaSound on to my raspberry pi using a mac.
I have already installed the CLI Tools and installed the zip file on the SD Card of the raspberry pi.
The pi shows up on the balenaCloud dashboard. The only problem is that I’m unable to install/Push the balenaSound file to the raspberry pi as the instructions on the balnea CLI tools page isn’t clear. I
tried installing the balenaSound file from the instructions I understood but I keep getting the same error. How do I overcome this? The screen shot of the error is given below.
Thanks in advance!

Same for me:Bildschirmfoto 2020-02-10 um 00.50.20


I suspect you downloaded the zip file from github? If so you need to extract the zip file, which will give you a local folder called balena-sound-master. You need to enter this folder and in there run the balena push command.

The file is missing in the master folder. I am unable to install/Push it

I see in your screenshots that you are not inside balena-sound-master folder. Before running balena push or git push you should cd into balena sound folder. For example if you have it on the desktop:

cd ~/Desktop/balena-sound-master
balena push <APP_NAME or DEVICE_IP>

See docs for git push and balena push difference.

got it!

but now only bluetooth is working…
Airplay is indicating running but I am unable to use it…

Does the balenaSound device appear as an audio output option for Airplay? Are there any error logs shown on the balenaCloud dashboard?

No error messages and the log even shows that airplay available as balena audio XXXX

Hi, can you share what device you are running balenaSound on? Also, how are you trying to use AirPlay?

Raspberry pi 3B

Via iPhone and Mac using Apple Music.

I’m trying to connect it by going to the control center> press and hold on now playing and then tap on airplay. There is nothing.

The same is with my Mac.

I click on then output icon and wait for all the airplay devices to show up but I see all my devices but the balena device.

Hi @manav103 one thing to check is that your Mac and the balena device are on exactly the same network. I have seen a case where the laptop was on a 5G network (or something slightly different) and the device was on another network, so airplay couldn’t find it.

It’s the same network I rechecked it twice.

I even saw my router settings(google Wifi)

Hello, so if you do balena scan you can find your device on the local network?

Yes I did find my raspberry pi

For some reason only Bluetooth works, I haven’t tried spotify as I don’t have premium,

I use Apple Music…

One other thing to check is that the device is getting discovered correctly over bonjour (the network service that airplay uses for device discovery). These mobile apps should help you test that: