BalenaOS on nvidia Jetson Nano devkit not booting to OS


I am trying balenaOS on NVIDIA Jetson Nano Devkit and using SD card Image to boot.
When I insert he SD card. the module is not getting booted up It hangs with constantly displaying NVIDIA Logo on screen,
I checked serial boot logs as well, bootlog prints for a while and stops. attached the same

used below image to create bootable SD card Image using balenaetcher from linux host: balena-cloud-jetson-nano-2.67.3+rev2-v12.3.0.img

followed below instructions:

Please help me on this.

bootlog on serial console:
BalenaOS_serial_Bootlog_nano_devkit_02102021.pdf (149.3 KB)

Hi Venkatraman,

I went through your logs and found some relevant information that made me suspect of an error with the SD Card. Apparently there’s a problem accessing the memory socket and files can’t be read.

Scanning mmc 1:c...
** Unable to read file / **
Card did not respond to voltage select!

I also found this Nvidia forum with a very similar pattern: Jetson Nano not booting, showing only nvidia logo on screen, Serial logs says MMC: no card present - Jetson Nano - NVIDIA Developer Forums

In the end, the user in that other forum solved the issue by replacing the Devkit with a new one. However, it might be worth trying to change the SD Card with a new one to see if that could be causing the problem.

Give it a try and good luck!

Thanks for the suggestion,

I have tried different Nano devkit with different SD card but no success. attaching the serial console log files, anything you suggest?

I have used Strontium Nitro A1 32GB microSD HC card to boot.BalenaOS_serial_Bootlog_nano_devkit_module2_02112021_1.pdf (113.4 KB) BalenaOS_serial_Bootlog_nano_devkit_module2_02112021_2.pdf (110.8 KB)

And I forgot to tell you, with the same previous board and SD card, and the second board and SD card I am able to flash and boot NVIDIA BSP and it is booting to desktop without any issue

If you are using a custom board, then the image we are providing does not have to work. Maybe that is why the system is not capable of using the memory properly and giving that error above.
I suggest we continue the discussion in this other thread since it seems to be pointing to the same: BalenaOS on nvidia Jetson Nano devkit not booting to OS -- emmc image