Jetson nano didn't boot with Balena OS

Hi everyone!

I have a Jetson Nano board. I want to use it with Balena Cloud. But the board won’t boot from Balena OS.
I tried Ubuntu from Nvidia site - it works fine.
I have tried many versions of Balena OS, two other SD cards. The Nvidia logo is displayed on the screen and nothing happens. It’s like if you turn on the board without a SD card. With only one version of the OS (2.43.0+rev1) I got boot with error message:
mount: mouting /dev/nmcblk0p1 on /rootfs failed: Invalid argument

My specification:
Jetson Nano model P3450
CAN ICES-3 (B)/NMB-3(B) 180-13449-DAAF-A02
SD cards: samsung EVO Plus 32 Gb, SanDisk Ultra 32 Gb
For flash SD cards: macOS Ventura 13.1 + BalenaEtcher 1.18.4

I would appreciate any help or advice on debugging this problem.

Best regards,

I couldn’t attach two images so I’m adding the bootload error here

Hello @gek404 first of all, welcome to the balena community!

Could you try to flash the balenaOS on the SD card using the Jetson Flasher tool from here GitHub - balena-os/jetson-flash: This tool allows users to flash BalenaOS on Jetson supported devices

Did you try the recommended (latest) balenaOS version?

Hello! Thanks!

I am using BalenaEtcher 1.18.4 with Macbook Pro (x86). Before that, I flashed my SD card in this way and it worked on other Jetson Nano. This does not work for the current board. I have seen recommendations for using jetson-flash. Today I will try it, although I do not fully understand why a separate firmware tool is needed. I’ll update this thread after trying to use jetson-flash.

Regarding the OS version. I tried the recommended OS version 2.98.12. Also tried almost all available versions (about 10). Also tried Open Balena version. The result was the same. I suspect that the problem is in the bootloader, more precisely in mounting the root file system or even earlier.

Thanks for your message @gek404 due the changes of the partitions on NVIDIA devices it is not possible to use Etcher at the moment. This is why we created the jetson flasher tool.

Just to understand the tool, let me quote here what the README says

The Jetson Flasher tool invokes NVIDIA’s proprietary software to properly partition the eMMC and place the required balenaOS software in the necessary location to make it bootable. Even on Jetson boards without eMMC, this tool may be necessary to initially flash balenaOS because of the way JetPack uses onboard QSPI flash memory for the bootloader. (In those cases, this tool can write to the QSPI so the device will be able to boot balenaOS from the SD card.)

Let us know if that works!

A bit late with the feedback.
I have now used jetson-flash inside Docker. With its help, it turned out to flash the PC. I consider the problem solved. Thanks @mpous for the help!

1 Like

Thanks for the confirmation @gek404

Let us know if we can help you with anything else :slight_smile:

1 Like