BalenaOS on nvidia Jetson Nano devkit not booting to OS -- emmc image


I am trying balenaOS on NVIDIA Jetson Nano Devkit and using emmc Image to boot on nvidia based customized carrier board.

the module is not getting booted up, It hangs with constantly displaying balenaOS Logo on screen,
I am unable to see serial console log as well. but my USB mouse and keyboards are getting detected as I can see num+lock and caps+lock keys are accessible.

used below image to flash emmc from linux host:

Installed all the dependencies
using Linux based host - Ubuntu 18
Run the cli, specifying desired device type: device type Jetson Nano emmc
flash command:
root@hx:/home/hx/BalenoOS# ./jetson-flash/bin/cmd.js -f balena-cloud-jetson-nano-emmc-2.67.3+rev2-dev-v12.3.0.img -m jetson-nano-emmc

followed below instructions:

Please help me on this.

Hi there, the image is purpose-built for the for the standard Jetson Nano Devkit, so it is possible that it just wouldn’t work on a customized carrier board. Is the carrier board something you’ve made in-house, or you can link us to it so we can have a look? In cases like this, where we don’t provide an Image for the specific board you are using, you can either build balenaOS for your board: Custom board support - Balena Documentation or we can do it for you if you are interested: balena - Scale pricing from prototype to enterprise usage

I am comminting here because you suggested me to move the discussion here from here(BalenaOS on nvidia Jetson Nano devkit not booting to OS - #8 by venkatraman)

I will not confuse you, very first I have tried with Nvidia nano devkit and it failed to boot. Once this is up I will go and check the carrier board, as you pointed it is custom build and I need to figure it out more for that.

The issue I am facing currently is with standard nvidia devkit.

Update: with Nano devkit and development Image I am now able to reach till here, _ _ ____ _____
| |__ __ _ | | ____ _ __ __ _ / __ \ / |
| _ \ / _ || | / __ | _ \ / _ | | | | |_

| |
) | () || || /| | | || () | | || | ) |
.__/ _
| _
/|| || _,| _/ |__/

Booted - Check your balenaCloud dashboard.
[ 25.724221] IPVS: Creating netns size=1920 id=2

balenaOS 2.67.3 balena ttyS0

balena login: [ 28.219050] ip6_tables: © 2000-2006 Netfilter Core Team
[ 32.417894] IPv6: ADDRCONF(NETDEV_UP): supervisor0: link is not ready

balena login:
balena login:
balena login: balena

Login incorrect

balena login:
balena login:
balena login:
balena login:
balena login: ba
Login timed o
balenaOS 2.67.3 balena ttyS0

balena login: [ 209.778142] IPVS: Creating netns size=1920 id=3

balena login:

What will be default password or login details? Or how to configure it? i am using headless via serial console

Hi, further to this I am able to boot to the OS on serial console,
I have used Nano devkit SD card development image here since I am not successful with production image any difference in both of these images?

But if I connect any interfaces like USB keyboard, mouse or HDMI display to the Nvidia Nano devkit, it is not booting or hangs in between sometime.

If HDMI display is connected, it is showing only Balena green logo and not going further , I am not able to see curser movement as well.

Anything else needs to be done for this for peripheral to work?


There are 2 images available in the dashboard for the Jetson Nano. One is named Jetson Nano SD, the other is Jetson Nano eMMC. One is for the devkit module, that boots off an sd-card, and the other is for the production module that has an eMMC. Both are images for the nvidia devkit carrier board.

There is another 3rd image, which is for the Jetson Nano Devkit 2GB, which has it’s own specific carrier board, and has only 2GB of RAM, unlike the modules above that have 4.

What kind of module are you using, 4G SD, 4G eMMC, 2G SD? And what carrier board? Is it some carrier board that is commercially available, the vendor offers a BSP for it?


  1. We have Jetson Nano Developer Kit |945-13450-0000-000 (4G module)with us and we have tried Nvidia Jetson Nano SD-CARD (NEW) image on this devkit.

With the above development image nano devkit we are able to boot to the OS only via serial console and we are not able to log in through Desktop GUI (using display), we see only Balena logo on display and nothing else.

We are not success to boot with Production image yet.

  1. Also we have our custom board which is based on Jetson Nano module which supports eMMC, we have tried Nvidia Jetson Nano eMMC (NEW), you can get more details on our custom board here, we have our customized BSP for this based on nvidia stock BSP:
    FLOYD Carrier for NVIDIA Jetson Nano & Xavier NX

With this we are not able to boot into the Balena OS, not even with serial console. Please suggest us to make progress and get this fully working.

Our first priority here is to prove that we can run Balena OS on Nano module + Floyd combination. Supporting all the board features.

Hi Venkat,

Since this thread is on the Forums as well, I wanted to share my response here for others’ benefit, but you can continue working with our engineers afterwards (as I’ll be sleeping). :slight_smile:

  1. What you’re seeing on the display actually indicates that you’ve booted successfully with balenaOS. balenaOS was developed to allow containers to work on edge devices and manage software / hardware updates remotely, so there’s no desktop environment (like Windows, Ubuntu, etc.) for you to interact with once it’s booted. After seeing the balena logo, you can just sign-in to your balenaCloud device and you should see the hardware provisioned there. At that point you can push software to the device (if you haven’t already) and otherwise become familiar with the dashboard UI for management and updates.

  2. We don’t today support Diamond Systems’ Floyd carrier board. We would like to though, so hopefully you can continue to work with us to make it a Community supported device type on balenaCloud!

Further to below query, we are able to boot to the OS via serial console and I see not having any packages are installed, and my device is not getting listed in BalenaCloud. cna you help me more on this? Like how do I add my device in Balena cloud and Open sessions to the container. Actually I wanted to test the serial port on my device.
I have two serial ports and want to create a loop between them and test the Hardware(RS232 and RS485 modes)

Now I am seeing my device listed in my BalenaCloud. and I get error if I try to access Terminal on local host. attached the screenshot. please help. Is it related to the network?

Here in terminal I can see only Host OS as the option if I click on it I get error saying
Connection error… retrying …

My question here is this terminal is same as linux terminal?
If I need to run some commands where shall I try?
for Balena CLI I need to download and install the Image, I do not have web browser etc to download it. I am not able to go to the desktop here, only able to access via serial console, and limited commands con be run from it.

so from where I need to download or install anything?

Or If I want to start some tests on hardware with commands where Can I check?

I recommend checking out the documentation for balena CLI, which you can find here: balena CLI Documentation - Balena Documentation

After you have the CLI installed, you can scan for your device on the local network with balena scan, and ssh into that device with balena ssh [your_device_address].

To answer your question about the dashboard, yes, the shell on the dashboard is equivalent to a normal Linux shell running on the device or through SSH. As far as the connection error, I’m not sure what’s causing that, is your device reporting as online?

What commands would you like to run? BalenaOS is essentially an operating system purpose-built for running containerized applications. You generally want to build and deploy your applications in containers, but if you’re looking for a simple and easy way to test the functionality of your device, you can run balena run -it debian from the host OS shell to download a Debian image and run a shell inside it, from which you can install applications normally (just keep in mind that this is inside a container, and your changes won’t necessarily persist).