balenaFin + CM3 + Windows IOT not booting after flashing. raspbian is working well

I’m using windows IOT dashboard to create boot image.

How to install windows IOT on balenaFin + CM3 (bcm2837) ?

Hey, an image for the balenaFin generally needs to support that hardware specifically, when you say raspbian is working fine, do you mean the image provided by us, available from here ?

no . I use image from + BalenaEtcher.
it’s working.

But i need windows IoT . So i try woeusb --device 17763.107.181026-1406.rs5_release_svc_prod2_amd64fre_IOTCORE_RPi.iso /dev/sdc to flash image.

try using windows iot dashboard to flash image. nothing work.

Does balenaFin + CM3 (rPI compute module 3 ) support windows IoT ?

Hi @stalker , I don’t think any one on the team has tried this before, but from a bit of searching, it seems it comes down to microsoft supporting the BSP and it seems like in 2018 there wasn’t yet support to the CM3 on window iot 10 . I’ll have a look around for some more info on the subject, but if it works on the standard CM3 carrier board, it should work on the fin (the fin OS images just have a special dtblob.bin on the boot partion to enable all the hardware).

CM3 is definitely not supported right now for Win10 IOT Core. I recently flashed a CM3 module with the Windows 10 IOT ISO, but haven’t yet worked past some of the boot issues. It’s something I would like to achieve, but the summer happened, so I’m just getting back into it.

I’ll keep the forum posted on successes and failures.

Hey Shaun,

Can I get a copy of the BSP to build a private Fin image?

Sure thing, it’s open source. :slight_smile: The Fin image is built from this repository

by building the fincm3 machine name. You can find some documentation on how to build it here (also requires some Yocto setup, just to be clear).

1 Like

Thank you :0)

Hello. After all, has anyone managed to boot Windows IOT on a BalenaFin + CM3 device?
When I tried to use BalenaEtcher I got a message that I should try Rufus. Rufus does not find the BalenaFin device. I’ll be back tonight with a few screenshots.

I have reached out internally and we’re looking into it; but I don’t think that Windows 10 IOT supports the CM3 modules at this point anyway. Unless you have some reason to think otherwise?