BalenaEtcher stopped working

I’m on a windows 10 lenovo x1 gen 7, and have previously used balenaetcher with no issues. This afternoon I attempted to flash a pop_os image on several different UBS drives and they all failed with the same error.

gui.js:44749 {“stack”:“Error: spawn C:\WINDOWS\system32\cmd.exe;C:\Users\Will MacKay\Desktop\platform-tools_r30.0.5-windows\platform-tools ENOENT\n at Process.ChildProcess._handle.onexit (internal/child_process.js:264:19)\n at onErrorNT (internal/child_process.js:456:16)\n at processTicksAndRejections (internal/process/task_queues.js:81:21)”,“message”:“spawn C:\WINDOWS\system32\cmd.exe;C:\Users\Will MacKay\Desktop\platform-tools_r30.0.5-windows\platform-tools ENOENT”,“errno”:“ENOENT”,“code”:“ENOENT”,“syscall”:“spawn C:\WINDOWS\system32\cmd.exe;C:\Users\Will MacKay\Desktop\platform-tools_r30.0.5-windows\platform-tools”,“path”:“platform-tools”,“spawnargs”:["-c",“tmp-4900-c53BnTuX9ViU”"],“cmd”:“tmp-4900-c53BnTuX9ViU”",“stdout”:"",“stderr”:""}

I am not sure what suddenly caused the program to stop working, but tried running as the admin with the same results.

I also uninstalled and reinstalled version 1.5.115

Thanks in advance

Hi there, two quick thoughts on this… First, can you flash other images, besides Pop_OS? Perhaps try Raspbian on an SD Card, or Fedora on one of the USB sticks. Let’s see if that works, in which case we know the Pop_OS file is not functional.

Second, do you have Windows Defender or other security/malware apps running that might be preventing access to the drive, keeping Etcher from writing to the drive?

Finally, it looks like Etcher is currently at v1.5.121, so it might be worth downloading and installing the latest release, as well. Hope that helps!

dtischler,

I updated to v1.5.121 and tried flashing different images onto different media and they all failed. What I found interesting is that the error message I posted above occurs right after I select what image to flash. The Windows defender settings are the same as the past when BalenaEtcher worked. Any other thoughts?

Well, it is certainly possible that Windows Updates or other background updates to Defender or other security applications can alter the behavior of a system, taking it from to working to non-functional without any input from a user.

With that said, you can try disabling any Defender or similar applications, just for testing purposes, and try flashing again. If that works, well, then once the flash is complete turn it back on and that’s that.

Alternatively, you can try the stand-alone executable version of Etcher, which does not physically install to the hard drive. Go to balenaEtcher - Flash OS images to SD cards & USB drives, and click the down arrow in the green bubble, to expand the list of download options. Choose the standalone .exe version, wait for download to complete, then navigate to the downloads folder and double click to launch it. See if that works any better for you. :slight_smile:

dtischler,

Thanks for the suggestions. I was able to get it working and wanted to share how I did it.

A while back I had added some system variables that affected Balena. I removed the added variables involving the “platform-tools” and Etcher still wasn’t working; the fix was that under System Variables, ComSpec was “C:\WINDOWS\system32\cmd.exe;” and Etcher was looking for “C:\WINDOWS\system32\cmd.exe”. Once I removed the semicolon Etcher worked.

Thanks again

Glad to hear you got it resolved!