balenaEtcher-Setup-1.5.76 going nowhere in Windows 10

I selected a .iso file just downloaded for Mint Linux and started the program but screen is stuck like this:

Were you asked for the Administrator password ?
Did it worked before ?

It never worked for me. I was not asked for
Admin password. After two attempts at re-installing, I gave up
and my flash drive was left in an unusable state. I was able to
restore my flash drive by using Acronis to wipe the drive.

    Rufus gave me no problem in creating the

bootable USB.

Hello @OldMoldy it seems you’re hitting a known issue where the progress bar is not updated when there’s been an error. I would suggest you download the latest etcher version (1.5.77 at the minute) which fixes that issue, and try again.
If you keep getting the same error, could you please send us the console logs? You can open it with ctrl + shift + i and then focusing the Console tab.

Thanks for the suggestion; however, I found
another way to deal with the issue and have moved on.

Good to know you found another way over it. Please let us know if you need further support!