Problem w/ BalenaEtcher and iOS 10.15.7

I recently downloaded a current version of etcher (1.5.109). I am running Mac OS X 10.15.7. After installing it I tried to flash a USB thumb drive, which was not successful.

When I start Etcher I am able to select “Flash from File”. I am also able to “Select Target”, which is my USB thumb drive. When I get to the “Flash” option I select it and it displays a dialog box that has a progress window that has not started yet along with the dialog box to enter my password. After I enter my password, the screen immediately goes back to the beginning “Flash from File” and “Select Target” and the progress bar is no longer there.

Obviously nothing ends up on the USB. Also, I have tried different USB’s and a different computer that is also running Mac OS, no success anywhere.

Any suggestions or ideas?

Thank you

Hello, thanks for reporting your issue. What do you see in the developer console? (press ctrl + shift + i then go to the console tab)?

Should I paste the results here?

@m4mgal3, yes please paste or attach the results here - thanks. Also:

  • I’ve just tested the same version of Etcher on the same version of macOS, and I could not reproduce the issue. However, something I had to do was to authorise Etcher by going to the macOS System Preference -> Security & Privacy -> General and authorise Etcher (I can’t remember the exact wording). So perhaps it is worth it to have a look there, in case there is anything pending authorisation.
  • The Etcher for Mac shortcut to show the developer console is CMD-ALT-I, or selecting Toggle Developer Tools on the View menu.


I have periodically checked the security tab to make sure there wasn’t a pending authorization and have not seen one yet.

I have attached a screenshot of the results.



By any chance, are you running Chrome Remote Desktop on your Mac? It’s been known to cause permission issues that affect balenaEtcher.


No - not using Chrome Remote Desktop


I downloaded the Linux version of Etcher and ran it in a virtual machine. I was able to flash my USB drive, but still no luck with Mac OS.

Glad to hear you got the image flashed, even if you did have to use a workaround…In the meantime, I have notified our Etcher maintainer to see if than can provide any more insight on what might be going on here.

Are you running Etcher from a non-admin account on your mac? This is known to be problematic as Etcher needs sudo permissions in order to spawn the flashing sub-process, otherwise it fails to spawn due to the lack of permissions.
An alternative might be to directly run Etcher using sudo, so you could try that instead and let us know if that’s an option

@thundron - you are correct. I have been running this from a non-admin account since I don’t normally operate out of my admin account. Once I switched over I was able to successfully flash a USB. If I could just remember that each time I need to use the program.

For future reference, what would be the proper sudo command to run the program?

Thank you for your help!


Try $ sudo /Applications/