BalenaEtcher made my Kingston DataTraveler 16gb unusable

You should warn people before using BalenaEtcher. I used it and it failed in the last stage where it checks if it succeeded. Can’t use my Kingston any more. Tried with Windows disk manager but i can not format it any more. I can create a partition but can not format it nor give it a drive letter. Also tried on another PC with another OS but same thing can’t format it any more.


Tried the repair instructions. But the clean command fails. It throws an error. In the event log i see the following message:

“Kan bepaalde sectoren op schijf ?\PhysicalDrive1 niet leegmaken. Foutcode: 5@0101000F”

Translated it says that it can not delete specific sectors on the drive.


Ok, found it. Had to rebuild the MBR and now everything is working again.


1 Like

Happy to hear that you succeeded @ctl

Let us know if we can help you more!

excuseme i am very new whit balena, and now my drive is unusable to.
where can I find the solution to repair it

Hello @jorm3046 welcome to the balena community!

Sorry to hear that this happened. Did you try this document? Etcher broke my USB stick … or did it?

Let us know if that helps!