Balena sound stops playing after using SUPPORT_DEVICE_NAME

Hi all,

I am having issues with my pi zero + hifiberry dac. It all worked as planned, but when I use the SUPPORT_DEVICE_NAMEdevive variable, I get no sound. Spotify says it is playing but it doesnt seem to be.

Has anyone had a similar issue?

Thanks

Hi there, just to clarify, are you referring to SOUND_DEVICE_NAME as mentioned here: https://sound.balenalabs.io/docs/customization#plugins ?

And, prior to setting that variable, sound was actually working?

Finally, have you tried rebooting the device at all?

Hi,
yep, thats the one. I follwed this Turn your old speakers or Hi-Fi into Bluetooth, Airplay and Spotify receivers with a Raspberry Pi and this step-by-step guide

Yes, It was working prior to setting that variable.
I have tried rebooting through the balenacloud and through power cycling the pi.

Actually, I just noticed that we opened a GitHub Issue yesterday, about no audio being played: multiroom: no sound · Issue #423 · balenalabs/balena-sound · GitHub. So, that might be the cause, but, I am interested to know if audio returns if you delete the SOUND_DEVICE_NAME variable, and reboot? Does it come back? Thanks!

Ah ok, I have deleted the variable but still no sound, even after reboot, and power cycling pi.

I’ll try adding the device again in the morning.

One last item to try, since you are using only one device, is to try setting the SOUND_MODE to STANDALONE as documented here: https://sound.balenalabs.io/docs/customization#plugins

See if that happens to work, while we continue investigating the issue. Thanks!

HI David,
I tried that but unfortunately didn’t seem to work. Not sure if it’s just something I did wrong on the configurations.

I re-flashed my SD card with the same file as yesterday, whilst balenacloud was doing its initial set up, i configured it all with name change, standalone etc and now it works fine.

I think there might be an issue with it re-running after making a change. But if it’s all done at the start it worked well for me. I am still just getting started with this so once I know more, I will open up the terminal and see if my system just isn’t stopping and re-starting the run operations properly.

Thanks for the suggestions and the great balena interface!

1 Like

@b-shah great to hear that you got it working with the re-flashed SD card and setting up the configuration again.

If you find out any more information or have any further issues then feel free to reply back here.

@shawaj It seems to have stopped working quite randomly. No changes made and now getting issues as per yesterday evening.

Hi there,

Could you navigate a browser to http://<DEVICE_IP>:3000/support substituting your PiZero’s IP address, and then paste the logging from that page into here?
Also, are all of the services started on the device when you look at the balenaCloud dashboard? If you have put the device into STANDALONE mode then the multiroom services will be stopped.

Phil

Hi Phil,

Thanks for your message, I have sent you a direct message with the logging for my device. It seems that I can see it and connect to it on airplay but no sound, and then can’t see it on bluetooth which is odd. Spotfiy now works perfectly

THanks,
Binit

Hi B. Shah and all,

Did you guys ultimately get this resolved? I’m having what looks like the same issue.

Pi Zero W with HifiBerry Zero DAC + getting no sound. Doesn’t seem to matter if I am using SOUND_DEVICE_NAME and BLUETOOTH_DEVICE_NAME. Otherwise followed the same guide, used “i2c_arm=on”,“spi=on”,“audio=off”, and have tried both hifiberry-dac and hifiberry-dacplus as values for BALENA_HOST_CONFIG_dtoverlay.

I reflashed the SD but still seem to be getting no luck… for a bit I could connect on bluetooth and AirPlay, now seems to drop when I do. The relevant parts of the log seem to be:

ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection terminated

and

ERROR librespot_playback::audio_backend::alsa] Alsa error PCM open ALSA function ‘snd_pcm_open’ failed with error ‘ECONNREFUSED: Connection refused’

Any insight you guys might have gotten would be greatly appreciated. Thank you!

Hi,

I have not had any joy sadly with this. The system has stopped working for me entirely with constant underruns with spotify, and no audio through airplay or bluetooth. Very frustrating as was working for spotify a few days ago.

I have re-flashed my SD card,

Thanks for the update, B.Shah.

I’d like to see if I can run in parallel to you to figure this out.

Do you still have SOUND_MODE on STANDALONE?

When it was working for you, were you using “i2c_arm=on”,“spi=on”,“audio=off”?

And finally, I saw that the documentation for DAC support said the Hifiberry Zero DAC used the “hifiberry-dac” dtoverlay, but we’re both using the newer Hifiberry Zero DAC +. What dtoverlay were you using when it worked?

Thank you!

Hi everyone, I just want to clarify a few things and see if I can help you out:

  • First, there is no env var SUPPORT_DEVICE_NAME. It’s either SOUND_DEVICE_NAME or BLUETOOTH_DEVICE_NAME as described here
  • You do not need to set dtparam "audio=off", in fact this is probably causing problems! I apologize I only now realized that this guide is outdated and instructs you to do so. I’ll fix it ASAP, please revert that change to "audio=on" :slight_smile:
  • Ensure you are running latest version of balenaSound v3.5.2 released March 8th. There was a bug with previous recent versions that was fixed in that release.
  • Finally, ensure your services are Running (if you are on STANDALONE mode then multiroom services will exit, that’s fine

For troubleshooting, if you can attach service logs plus the output of http://<DEVICE_IP>:3000/support then that will help a lot.

Hi,
sorry, i had mis-typed the sound_device_name.
I have made the changes as described, however it didn’t seem to fix the issues. I can’t find the latest balena sound release. For the Pi zero i am using, i can only get v2.54.2 rev1.

balena-sound_hidden-frost-19.03.21_19 00 37_(+0000).log (78.3 KB)

http://80.6.1.151:3000/support

Hey, I’m confident this is a bug that was fixed recently (two weeks ago if i recall correctly). Can you try re-deploying? If you are not sure how to do it I suggest you visit https://hub.balena.io/, search for balenaSound and click “Deploy with balena”. That will take you to the balena dashboard where a popup with instructions to “Deploy to existing application” will show (if it want’s to create a new application choose the “Use an existing application” option, ill share some screenshots to clarify.


Thank you for this! I’ve taken these steps.

It currently shows that I am building release 5ac5b67, but opening up the release states that deployment failed due to a build failure. The Build Overview in the Build log said it has completed, and was successfully created, but included this error:

[Error] Error:: It is necessary that each release that has a release version1 and has a status that is equal to “success” and is not invalidated, belongs to an application that owns exactly one release that has a release version2 that is equal to the release version1 and has a status that is equal to “success” and is not invalidated.

I will try to build it again, and if that doesn’t work, I’ll try to flash again. Please let me know if you have other thoughts!

Thank you

Hi, Thanks for reaching out. Can you provide more log entries (or complete log) around this error?

Hi Nitish and tmigone,

Thank you for the help and follow up. I just reflashed and things are working! It looks like the bug was fixed. I was previously using v3.5.2, and it says I’m using it now, so I don’t know what changed. I noticed the Getting started - Home link says 3.4.2, but the Deploy with Balena button does deploy on 3.5.2. Please let me know if I can share anything else that would be helpful.

@B.Shah , I hope it starts working for you!