balena home assistant: status online (heartbeat only)

Looking to build balena home-assistant on a Banana Pi. Following this deployment:

I then etch the image to the host SD card, and power it up.

I can see the device in the cloud fleet manager, but it is constantly in Online (Heartbeat only) mode. Checking the documentation that would indicate the is device is unable to connect to cloudlink (e.g. a firewall is blocking VPN traffic), and won’t be able to provide remote SSH connections. I can’t understand why, as there is local network connectivity and I have other balena hosts that connect just fine.

what’s my next move?

I’ll add, here is the only entries from the log:

Creating network 'default'

My LAN → WAN setting is Allow all.

As a test, I installed BalenaSound on the same SD and hardware and it just works. I’ll call this post good now, and will further investigate how home-assistant is installed.

Actually, very strange. The same hardware with BalenaSound running on it does work as a Spotify Connect client, but still has the Online (Heartbeat Only).

Anyone have any ideas why that is the case?

nmap -p 443
Starting Nmap 7.80 ( ) at 2022-11-12 23:28 GMT
Nmap scan report for (
Host is up (0.093s latency).
Other addresses for (not scanned): 2600:1f18:6600:7f00:3b29:5e04:b6af:68b7 2600:1f18:6600:7f01:b5fc:e785:75fc:2e80
rDNS record for

443/tcp open  https

Nmap done: 1 IP address (1 host up) scanned in 0.25 seconds

Think it’s time to retire the BananaPi. It did work before (on a different project), but it’s not working now. I put the same application on an RPi3 and it just worked.

Can I suggest you either delete this thread or else edit the first post and add “Nevermind” at the top? Considering your last post, it’s all pretty pointless and was a total waste of time to read.

I’m sorry that you totally wasted your time, unfortunately there is nothing I can do to get that back for you. Furthermore, I do not have permissions to delete posts (even my own) and nor can I edit it. Ironically replying to you now will be even more of your time wasted.

Hello everyone. @reryro We try to keep things civil and stand against discouragement of discussion and rudeness in general; if this post was a waste of time for you to read, then that is unfortunate. @n1md4 asked some valid questions, and it is very possible that other users may have experienced the same issues. As such, stating their problem and outcome will be helpful to those users. Finally, we always try to encourage public discussion of technical issues and their solutions to promote collaboration.
Further discouragement of such discourse will not be acceptable.

1 Like

Oh boo hoo. TL;DR

@n1md4, Interesting info, thank you for sharing. It looks like the VPN connection of the Banana Pi isn’t consistent. If the RPi3 which worked for you afterwards is on the same network as the Banana Pi, then the issue with home-assistant / balenaSound on the Banana Pi may be due to the device-type-specific OS, or the hardware itself. Are these 2 devices connecting to the network in the same way?

If you’d like to debug further instead of retiring the SBC, could you paste some VPN logs of the device when it’s in Online (Heartbeat Only) mode? This would require local network access to the device, and the device to be running a development OS. You can use something like journalctl -u openvpn -xef.

Happy holidays!

1 Like

The devices were configured on the same network.

The host OS version available to install on the BananaPi is Resin OS 2.12.7+rev4 and the Supervisor version is 7.4.3.

I have today reinstalled BalenaSound, and the same happens. Services run, but the VPN is not available.

Attempting to connect to the device locally fails though:

~/c/g/balena> balena ssh
user1@ Permission denied (publickey).
SSH: Process exited with non-zero status code "255"

Are the SSH keys correctly configured in balenaCloud? See:
Are you accidentally using `sudo`?

SSH keys are configured correctly as I am able to access other devices in this manner.

This feels like the hardware and software is fine, but perhaps there has been a subtle change in how the VPN now works compared with the older host OS or Supervisor version.

Hi, can you please try the new v2.108.9 image for the Banana Pi M1+ from the cloud?

1 Like

Hi, I will try the new image. If that does not work I will also try the development OS. Will report back soon.

The new 2.108.9 image works, VPN access restored. Out of curiosity, do you know what the fix was in the newest version?