Flash failed ! Etcher keeps on deleting the partion

Help will be appreciated.
I’ve been trying to flash a Linux iso; every time I get flash failed I checked my usb bc after I reinsert it today it asked me to format it so tried to do it, I couldn’t. I found that it is bc there’s volume/partition was deleted. I created a new volume, tried the flash again & went back to square one -USB partion deleted. I have no idea of how to fix this. I’ve used different usbs(3) & multiple iso images. I use windows 10 & BalenaEtcher 1.5.116. The drivethumb & sd cards I used they’re all kingston.

Hello @mindinmotion

Welcome to the Balena Forums.

When this issue occurs please press ‘Ctrl-Shift-I’ in Etcher and post the output from the ‘Console’ log here. Please could you also let us know which Linux iso you are trying to flash so that we can try to reproduce the issue if necessary.

I tried khali linux1st & ubunto as Im not sure the nano jetson dev kit supports kali linux

It had to do with the security settings

the feature is off now & it’s working

thank you