Balena Dashboard offline in main browser session

Hi all,

A few of us at our company have noticed that the Balena dashboard is suddenly showing offline for us but only in our main browser sessions. If we open a guest session it works fine.

I noticed that there’s an error being thrown from a timeout here: image

If anyone else has encountered this I’d love to hear what you did to fix it. Thanks!

This is what the dashboard shows image

Hello, this is strange, Have you tried clearing up cache on your browser?

I did and that fixed it. Thanks! Not sure what could have caused this.

Are you running Chrome browser? My first thought was, this appears to have been due to stale DNS cache in your browser; the maintenance window our infrastructure passed through on May 9th [1] - which involved changing some DNS entries - would seem to correlate roughly with the timing. But the TTL doesn’t see mright as that was quite some time ago compared to what is by all reports a 1 minute TTL for the chrome internal DNS cache [2]. This possibly indicates that some other HTTP resource, perhaps a script or XHR response, was cached which misled the dashboard in some other way.

[1] - displays the history as you scroll down.
[2] -