balena dash services not working in cloud

Hello,
I am having some issues trying to use balena cloud with balena Dash. I used the tutorial blog on how to make a web frame in 30 minutes, and I followed all of the directions exactly, but I still can’t get it to work. I have balena CLI installed I think, (I am able to sign in and am able to see the version, help, etc) I installed balena Dash and I get the Unicorn (with a santa hat).

I have a R PI 3b+

once the device starts, all of the logs show the devices not working. the log repeats with the same notes, this is part of it:

Service exited ‘wpe sha256:5b03b6592151ddee11c38b02abdaa81a3990617e47274573dc46dd39ab65fdd8’
01.01.20 16:08:50 (-0800) Restarting service ‘wifi-connect sha256:73c90ba7e76f9ea47eb4f15fd2be61c68e54b2e0662720bb2a47d1d78c0a02c0’
01.01.20 16:07:48 (-0800) wifi-connect start.sh: line 2: $’\r’: command not found

01.01.20 16:09:13 (-0800) scheduler /bin/sh: /usr/src/start.sh: not found
01.01.20 16:09:15 (-0800) Service exited 'scheduler
01.01.20 16:09:16 (-0800) Restarting service ‘wpe sha256:5b03b6592151ddee11c38b02abdaa81a3990617e47274573dc46dd39ab65fdd8’
01.01.20 16:08:12 (-0800) wpe standard_init_linux.go:207: exec user process caused “no such file or directory”
01.01.20 16:09:16 (-0800) wpe standard_init_linux.go:207: exec user process caused “no such file or directory”
01.01.20 16:09:17 (-0800) Service exited 'wpe
01.01.20 16:09:52 (-0800) Restarting service ‘wifi-connect sha256:73c90ba7e76f9ea47eb4f15fd2be61c68e54b2e0662720bb2a47d1d78c0a02c0’
20 16:09:52 (-0800) wifi-connect start.sh: line 31: syntax error: unexpected end of file
01.01.20 16:09:53 (-0800) Service exited ‘wifi-connect sha256:73c90ba7e76f9ea47eb4f15fd2be61c68e54b2e0662720bb2a47d1d78c0a02c0’
01.01.20 16:10:17 (-0800) Restarting service ‘scheduler sha256:fe024299e9a38d0289dcde781072c5b63154fcfb8b383805bea922d33abf16da’
01.01.20 16:09:13 (-0800) scheduler /bin/sh: /usr/src/start.sh: not found
01.01.20 16:10:16 (-0800) scheduler /bin/sh: /usr/src/start.sh: not found
01.01.20 16:10:55 (-0800) Service exited ‘wifi-connect sha256:73c90ba7e76f9ea47eb4f15fd2be61c68e54b2e0662720bb2a47d1d78c0a02c0’
01.01.20 16:11:20 (-0800) Restarting service ‘scheduler sha256:fe024299e9a38d0289dcde781072c5b63154fcfb8b383805bea922d33abf16da’
01.01.20 16:10:16 (-0800) scheduler /bin/sh: /usr/src/start.sh: not found

any help would be appreciated.

Hi,

I tried to clone and push the balena Dash (https://github.com/balena-io-projects/balena-dash) project just now and it worked fine on my RPI 3b+. The message indicate that the scripts line endings might have been changed to \r\n, which can confuse the linux shells. Did you change anything in the files or stored them somewhere else using a Windows machine?

yes, I think that is possible, I was having difficulty installing balena cli, and I tried multiple methods to do it. I have one from the windows install package, one form the standalone package, and the git clones of balena cli and balena dash.

the windows install version is inside program files, as stated in the blog.
the standalone version I grabbed and put into my main C:/ directory.
the git clone versions are in C:/users/“user” directory.

Apart from moving the standalone version to the C:/ directory, I have not moved any of the other files.

Hi @hetco12, as noted above, this sounds related to Windows line endings specifically when you clone the project with Git and then push using balena push. There is an answer here piHole webinterface not reachable that gives a couple of options for dealing with this, and so I’d suggest you give one of those a try and let us know if you are still having difficulty.

It works! thank you for the help!