Balena Cloud - device connects by ethernet, not by wifi

Good evening
Please may I ask for help. I am unable to connect my devices on wifi:

raspberry pi 3B

Fleet: I have had balena-sense (air quality monitor), and kerberos (security camera), working in my dashboard.

Initially they connected by wifi no problems.
As far as I am aware there has been no changes to my router configuration.

Now I can’t connect with wifi (I have let it try for >10mins)
They connect by ethernet.
When ethernet cable unplugged the ACT LED on the Pi flashes (*_*_*_*____*_*_*_*____ ).
Terminal in device summary states: The terminal is unavailable because your device is not connected to the VPN
I have checked the balena-wifi-01 in resin-boot/system-connections and it looks correct:






I have tplink Deco mesh system.
It is broadcasting on channel 12 on the 2.4GHz band - there is no way to change this it seems. I have read about a requirement for channel 11 or lower but this was a few years ago, and as previously mentioned they were connecting over wifi initially. I live in the country with no close neighbours and no wifi congestion.
I also have balena-print and PiHole and they are working fine.

I have looked through the help pages and I think the next thing I need to look at is port 443. Is someone able to guide me through this please? I am very new to this so please treat me as a complete novice!

Sorry for the long post, and thank you in anticipation.

Sorry, I should have also mentioned I have tried re-flashing the SD card and also tried another SD card.
I have also run Raspberry Pi OS on the same Pi3B and confirmed the wifi hardware works.

Hey there, welcome to the forums.

Are you able to check from the router/access point side if these devices are connected? If you take the MAC address from the balenaCloud dashboard, you should be able to find a status page that shows all the connected devices to determine if a WiFi connection is actually being established or not.

If it is connected to the WiFi, this will then lead us down the path of debugging the connection and checking ports like 443 as you say (although it’s odd that these devices would have an issue when you have other devices working OK).

If it’s not connected to the WiFi, maybe the channel 12 thing is also an indicator. It is possible to set the country code on balena devices (see here) but again it’s strange that it would be required on these devices when you have others working fine.

Could you also confirm if all of your devices are Pi 3B, or are the balena-print and PiHole ones something different? It would also be worth determining if they are actually Pi 3B or 3B+ devices. I think it’s printed on the board but IIRC the 3B+ devices have a silver chip whereas the 3B are black - just an easy way to tell at a glance. :slight_smile:

Did anything change with your WiFi configuration or network configuration when the devices stopped working? It’s very strange that working devices would just stop connecting one day.

Thank you very much.

I shall endeavour to do those checks tomorrow and report back tomorrow.


No, not that I am aware of.

I have checked the wifi status page. No device with the MAC address from the balenaCloud dashboard is visible.

I can confirm that all devices are a Raspberry Pi 3B (Raspberry Pi 3 Model B V1.2)

Thank you. I shutdown the device (connected to it via ethernet), and put the SD card in my Mac. I have added “country”:“GB” to the config.json using Atom. Saved, and ejected the SD card.
On restarting the Pi it now connects to wifi and it is both discovered and online in the balenaCloud dashboard, and I can see its MAC address from my router’s side.

So, thank you very much indeed for your help and very clear instructions. I very much appreciate it.

1 Like

Great news, glad you got it sorted!